commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack, Paul" <pj...@sfaf.org>
Subject RE: [VOTE][Collections] Naming conventions
Date Tue, 02 Jul 2002 16:12:10 GMT
Can we soften the convention for decorator names?  I think xxxedYYY is 
an ideal, but sometimes doesn't work.  (Even java.util.Collections 
uses "unmodifiableList" instead of "unmodifiabledList").  

I think the convention should be xxxedYYY where possible, otherwise
<adjective>YYY.  I'd prefer to keep ListUtils.lazyList(List) instead
of ListUtils.laziedList(List).

-Paul


> Thanks to Stephen, we now have a "DEVELOPERS-GUIDE" which 
> explicitly lists the conventions we are voting on.  The 
> commit will act 
> as a standard commit-then-review, so if you have problems with the 
> conventions, -1 the commit with your reasons and we'll work 
> from there.
> 
> http://cvs.apache.org/viewcvs.cgi/*checkout*/jakarta-commons/c
> ollections/DEVELOPERS-GUIDE.html
> 
> regards,
> michael


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message