commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack, Paul" <pj...@sfaf.org>
Subject RE: [VOTE][Collections] Naming conventions
Date Tue, 09 Jul 2002 03:44:34 GMT
Hi, I'm not sure what's happening in terms of the voting
process on the naming conventions...actually I'm not quite
sure what the voting process is, exactly.  But, I thought
it'd be helpful to put together a comparison of the current
public API with the proposed naming convention changes:

http://www.geocities.com/apachecollections/Conv.html

Thought this might help people have something concrete to
vote on...

-Paul


> -----Original Message-----
> From: Stephen Colebourne [mailto:scolebourne@btopenworld.com]
> Sent: Tuesday, July 02, 2002 12:15 PM
> To: Jakarta Commons Developers List
> Subject: Re: [VOTE][Collections] Naming conventions
> 
> 
> +1 for the naming conventions change
> 
> Could the lazy method become lazilyInstantiatedList() rather than
> lazyList()??
> Seems more descriptive (but longer)
> 
> Stephen
> 
> ----- Original Message -----
> From: "Michael A. Smith" <mas@apache.org>
> To: "Jakarta Commons Developers List" <commons-dev@jakarta.apache.org>
> Sent: Tuesday, July 02, 2002 5:53 PM
> Subject: RE: [VOTE][Collections] Naming conventions
> 
> 
> > On Tue, 2 Jul 2002, Jack, Paul wrote:
> > > Can we soften the convention for decorator names?  I 
> think xxxedYYY is
> > > an ideal, but sometimes doesn't work.  (Even java.util.Collections
> > > uses "unmodifiableList" instead of "unmodifiabledList").
> > >
> > > I think the convention should be xxxedYYY where possible, 
> otherwise
> > > <adjective>YYY.  I'd prefer to keep 
> ListUtils.lazyList(List) instead
> > > of ListUtils.laziedList(List).
> >
> > yeah, I was thinking about that too...  I'll update it tonight.
> >
> > michael
> >
> >
> > --
> > To unsubscribe, e-mail:
> <mailto:commons-dev-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:commons-dev-help@jakarta.apache.org>
> >
> 
> 
> --
> To unsubscribe, e-mail:   
<mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:commons-dev-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message