commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Dever <>
Subject [vote][httpclient] rename methods that set the socket timeout to setSocketTimeout
Date Thu, 01 Aug 2002 00:50:00 GMT
1) Rename HttpConnection.setSoTimeout to be
2) Rename HttpClient.setTimeout to HttpClient.setSocketTimeout

To bring consistancy and clarity to the methods that set the socket

HttpConnection.setSoTimeout was likely named that way becuase it is
basicly a pass through that calls Socket.setSoTimeout of the underlying
socket object.  This method was added in december after the alpha1
release so we should be free to change it.  Similar story for
HttpClient.setTimeout, but it was added much more recently.

Other choices would be to:
a) Change both to setSoTimeout - it is unfortunate that the underlying
socket is named this, because the name is ambiguous.  What does So mean
anyway?  So what?  Star Office? Shared Object?  I guess it means Socket,
so lets use that.
b) Change both to be setTimeout - but timeout of what?  Read the
documentation to find out it means socket.  What if we add another
timeout value for somthing else?  then we will be forced to use
setXXXTimeout and leave the inconsistant setTimeout as depricated or as
a inconsistancy.
c) do nothing - that leave the problems of a) and b) in addition to the

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message