commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Colebourne" <scolebou...@btopenworld.com>
Subject Re: [lang] [patch] Numbers.containsDigits(String)
Date Tue, 02 Jul 2002 00:10:21 GMT
From: "Rand McNeely" <rand_mcneely@yahoo.com>
> I'll be happy to write the unit test.
;-)

> rename containsDigits to isOnlyDigits ("a9ez" contains digits)
I agree, we need to confer on this however

> and as noted there may be some performance issues in the
> isNumber(String) method.
Probably not worth worrying about

>  Also, is there a reason we don't have a maximum(int,int,int) for
> completeness (as far as that goes, what about longs, etc - perhaps the
> method should be changed to use longs instead of ints)?
I added maximum as I checked in your patch.

> Other methods that might be nice but can wait until a 1.0 release are
> operators for the primitive wrappers (add(Integer a,Integer b), etc).
+1, but less important than the tests

Stephen

> > -----Original Message-----
> > From: Stephen Colebourne [mailto:scolebourne@btopenworld.com]
> > Sent: Monday, July 01, 2002 6:46 PM
> > To: Jakarta Commons Developers List
> > Subject: Re: [lang] [patch] Numbers.containsDigits(String)
> >
> > Patch applied, thanks.
> >
> > Are there any more changes you want to make to Numbers? (If you'd like
> to
> > help a Numbers unit test would be useful!)
> >
> > Stephen
> >
> > ----- Original Message -----
> > From: "Rand McNeely" <rand_mcneely@yahoo.com>
> > To: "'Jakarta Commons Developers List'"
> <commons-dev@jakarta.apache.org>
> > Sent: Tuesday, July 02, 2002 12:06 AM
> > Subject: [lang] [patch] Numbers.containsDigits(String)
> >
> >
> > >
> > >
> > > > -----Original Message-----
> > > > From: Stephen Colebourne [mailto:scolebourne@btopenworld.com]
> > > > Sent: Monday, July 01, 2002 6:02 PM
> > > > To: Jakarta Commons Developers List
> > > > Subject: Re: [lang] is there a release on the visible horizon?
> > > >
> > > > +1, please submit a patch
> > > >
> > > > Stephen
> > > >
> > > > ----- Original Message -----
> > > > From: "Rand McNeely" <rand_mcneely@yahoo.com>
> > > > To: "'Jakarta Commons Developers List'"
> > > <commons-dev@jakarta.apache.org>
> > > > Sent: Monday, July 01, 2002 10:41 PM
> > > > Subject: RE: [lang] is there a release on the visible horizon?
> > > >
> > > >
> > > > >
> > > > > >
> > > > > > > > 6) Numbers has a lot of comments about future things.
Plus
> > > > > > containsDigits()
> > > > > > > > has question marks against the null handling
> > > > > > >
> > > > > > > Question marks meaning, should containsDigit consider null
> to
> > > > > contain
> > > > > > > digits or not, or should it not even check.
> > > > > > Or should it throw an exception (and which one)
> > > > > >
> > > > >
> > > > > I think the current implementation for nulls is fine but there
> is
> > > one
> > > > > other problem, the method will return true if passed "".  I can
> go
> > > ahead
> > > > > and take care of this.
> > > > >
> > > > > Rand
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > To unsubscribe, e-mail:
> > > > <mailto:commons-dev-unsubscribe@jakarta.apache.org>
> > > > > For additional commands, e-mail:
> > > > <mailto:commons-dev-help@jakarta.apache.org>
> > > > >
> > > >
> > > >
> > > > --
> > > > To unsubscribe, e-mail:   <mailto:commons-dev-
> > > > unsubscribe@jakarta.apache.org>
> > > > For additional commands, e-mail: <mailto:commons-dev-
> > > > help@jakarta.apache.org>
> > >
> >
> >
> >
> ------------------------------------------------------------------------
> --
> > --
> > ----
> >
> >
> > > --
> > > To unsubscribe, e-mail:
> > <mailto:commons-dev-unsubscribe@jakarta.apache.org>
> > > For additional commands, e-mail:
> > <mailto:commons-dev-help@jakarta.apache.org>
> >
> >
> > --
> > To unsubscribe, e-mail:   <mailto:commons-dev-
> > unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: <mailto:commons-dev-
> > help@jakarta.apache.org>
>
>
> --
> To unsubscribe, e-mail:
<mailto:commons-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:commons-dev-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message