commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Colebourne" <scolebou...@btopenworld.com>
Subject Re: [VOTE][Collections] Naming conventions
Date Tue, 02 Jul 2002 19:15:10 GMT
+1 for the naming conventions change

Could the lazy method become lazilyInstantiatedList() rather than
lazyList()??
Seems more descriptive (but longer)

Stephen

----- Original Message -----
From: "Michael A. Smith" <mas@apache.org>
To: "Jakarta Commons Developers List" <commons-dev@jakarta.apache.org>
Sent: Tuesday, July 02, 2002 5:53 PM
Subject: RE: [VOTE][Collections] Naming conventions


> On Tue, 2 Jul 2002, Jack, Paul wrote:
> > Can we soften the convention for decorator names?  I think xxxedYYY is
> > an ideal, but sometimes doesn't work.  (Even java.util.Collections
> > uses "unmodifiableList" instead of "unmodifiabledList").
> >
> > I think the convention should be xxxedYYY where possible, otherwise
> > <adjective>YYY.  I'd prefer to keep ListUtils.lazyList(List) instead
> > of ListUtils.laziedList(List).
>
> yeah, I was thinking about that too...  I'll update it tonight.
>
> michael
>
>
> --
> To unsubscribe, e-mail:
<mailto:commons-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:commons-dev-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message