commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <>
Subject Re: [Lang] Increasing its role
Date Wed, 19 Jun 2002 16:50:48 GMT

On Wed, 19 Jun 2002 wrote:

> OK. Like collections will have, there should be a note somewhere in
> the project (developers guide?) to say that is the naming convention.

Sounds good.

> No, what I meant was an instantiable StringBuffer, not a StringBufferUtils. Thus you
> UStringBuffer buf = new UStringBuffer();
> thus the buffer can be manipulated accordingly. (UStringBuffer would implement all the
methods of StringBuffer for compatability). BTW, there is probably a better name!
> Also, there was a discussion on JavaLobby recently where direct manipulation of char
arrays was requested. So maybe there should be a Chars utility class with all the functionality,
which Strings and UStringBuffer delegate to.

Both sound good. I'm just chomping at maintaining the same functionality
three times.

> > Once Lang is released, then I can release a 1.0 of String taglib depending
> > on it. So time for me to focus hard on Lang I think.
> All makes sense. Hopefully when my CVS is confirmed I can contribute?

Would be great. Do you want to start by pushing your serialisation cloner
in? I haven't checked it yet, but it sounds far more mature than the one
I have.

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message