commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Colebourne" <scolebou...@btopenworld.com>
Subject Re: [VOTE][Collections] Naming conventions
Date Tue, 25 Jun 2002 14:02:05 GMT
Proposed change:
> The discussion culminated in a summary by Stephen:
>
http://nagoya.apache.org/eyebrowse/ReadMsg?listName=commons-dev@jakarta.apac
he.org&msgId=366210
> http://marc.theaimsgroup.com/?l=jakarta-commons-dev&m=102416074321189&w=2
> http://www.mail-archive.com/commons-dev@jakarta.apache.org/msg08316.html
> [use whatever archive you prefer]

Reason for vote:
Aaron -1ed a change that I was about to make to the CVS.

Answers to your specific Qs:
> What's "add decorators" mean, precisely?
Decorators refers to adding functionality around an interface, exactly as
unmodifiable and synchronized do in java.util.Collections. (aka wrappers)

>  What's going into SetUtils, TreeUtils?
Any decorators that return a Set or SortedSet. Also any other useful
management code for Sets.

> Are we voting on taking a bunch of the wrapper classes (e.g.,
> FilterIterator), and hiding them as package-scoped static, inner classes?
Not yet, but the proposal indicates that new decorators (wrappers) will
follow the naming convention, ie. to be package-scoped static, inner
classes.

> On moving some methods around?
No released methods move. Unreleased methods in
PredicateUtils/LazyCollections/SimpleObjectFactory are affected.

>  Are we voting on a naming convention?
> Specific changes?
Both. The naming convention implies/requires changes.

>  On a guideline of having fewer than 60 classes in
> commons.collections?
This has never been mentioned

Stephen

----- Original Message -----
From: "Waldhoff, Rodney" <rwaldhof@us.britannica.com>
To: "'Jakarta Commons Developers List '" <commons-dev@jakarta.apache.org>
Sent: Tuesday, June 25, 2002 2:42 PM
Subject: RE: [VOTE][Collections] Naming conventions


> Shouldn't this be covered by the regular commit-then-review process?
>
> I haven't followed the (voluminous) threads leading up to this very
> carefully, but to be prefectly honest, it's not clear to me what we're
> voting on.
>
> What's "add decorators" mean, precisely?  What's going into SetUtils,
> TreeUtils? Are we voting on taking a bunch of the wrapper classes (e.g.,
> FilterIterator), and hiding them as package-scoped static, inner classes?
> On moving some methods around? Are we voting on a naming convention?
> Specific changes?  On a guideline of having fewer than 60 classes in
> commons.collections?
>
> Can we make or propose *specific* changes and then vote?  Because I don't
> understand what I'm being asked to vote for.
>


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message