commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack, Paul" <>
Subject RE: [collections] Naming of collection wrappers classes (Predicat eUtils et al)
Date Mon, 20 May 2002 17:11:08 GMT
> Thus I propose splitting PredicateUtils in two:
> PredicateCollections  (#1 above)
> PredicateUtils  (#2 above)

Well, that still leaves us with the problem that PredicateUtils
doesn't contain all of the predicate utils.  Other ideas:

1.  Move PredicateUtils.and, .or, .not, .instanceof, .TRUE and
.FALSE into CollectionUtils; rename PredicateUtils to 

2.  Duplicate the static predicate methods in CollectionUtils
in PredicateUtils, so that one class's static methods invoke
the other's.

Also, I noticed that the inner class for the instanceof predicate
was declared public, whereas the other inner classes were declared
private.  Was that deliberate?


To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message