commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Waldhoff, Rodney" <rwald...@us.britannica.com>
Subject RE: [dbcp] does not compile with JDK1.4.0
Date Tue, 28 May 2002 12:55:12 GMT
Thanks Jean-frederic.

For many of the classes there's already some
Ant-filter-token-replacement/conditional-compilation magic that will
generate JDBC3 friendly builds when compiled under JDK 1.4, and JDBC2
friendly builds otherwise.

It looks like Glen added DelegatingResultSet after these changes were
applied, and in the process we missed some JDBC2/JDBC3 issues.  

There's no chance of me getting to this today. Can someone else take a look?

Is there some way we can get gump to do both a JDK 1.3 *and* a JDK 1.4
build?  Then we would have seen caught this problem a couple of weeks ago.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message