commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Colebourne" <>
Subject [collections] Naming of collection wrappers classes (PredicateUtils et al)
Date Sun, 19 May 2002 10:45:26 GMT
The thread on the possible inclusion of another group of collection wrappers
has made me wonder if the PredicateUtils was named correctly. PredicateUtils
contains two groups of code:
1) Collection wrappers to provide the entry to collection checking
2) Commonly used predicates (And, Or, Not, True, False, InstanceOf)

I am currently developing another group of collection wrappers which also
rely on Predicate. Also, there are other classes in the commons collections
area that use Predicates (CollectionUtils, FilterIterator for example).

Thus I propose splitting PredicateUtils in two:
PredicateCollections  (#1 above)
PredicateUtils  (#2 above)
(This can be done as PredicateUtils isn't in a release yet)
This would then cause the proposed LazyUtils to be named LazyCollections.

IMHO, the change of name would better clarify the purpose of these
collection wrapper classes. If agreed, I will do the split.


To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message