commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerhard Froehlich" <g-froehl...@gmx.de>
Subject [HTTPCLIENT] possible bug?
Date Sat, 20 Apr 2002 09:59:31 GMT
Hi,
we have following bug -relating the httpclient- in Cocoon:

<description>
<snip/>
I have written a simple web-application consisting of an XSP file (
zipcode-info.xsp ) and an XSL stylesheet ( zipcode-info.xsl ) that accesses
two SOAP services at http://alethea.net:80/webservices/LocalTime.asmx and
http://www.vbws.com:80/services/weatherretriever.asmx ( I found these at
http://www.xmethods.org  from .asmx, I guess they are .Net web services and
the HTTP server is IIS ) using the SOAP logicsheet. This application worked
fine from my office machine ( behind a firewall, so I had to specify http
proxy host and port ), but failed to work ( first, it threw an exception "-1
port out of range" and then when I explicitly specified port 80, it just
hung waiting for a response from the service ) from my home computer ( no
firewall ).

I should add that access to web services deployed under TomCat works fine (
as long as you explicitly specify port 80 for http ).

I looked into the code and figured out that the use of httpclient code (
from org.apache.commons.httpclient.* ) in file SOAPHelper.java is the
culprit. Replaced this file with another ( included in the mail ) that uses
the JDK classes for HTTP transport and everything worked fine.
<snip/>
<description>

TIA for your responses!

  ~Gerhard

-----------------------------------
Boren's Law: When in doubt, mumble. 
-----------------------------------


--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message