commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Waldhoff, Rodney" <>
Subject RE: [pool] 1.0 release soon (was RE: [pool] PROPOSAL: add collect ing of statistics to pool implementations)
Date Mon, 29 Apr 2002 20:05:21 GMT
>> If anyone is strongly bothered by ObjectPool.numIdle() and
>> ObjectPool.numActive() versus the getXXX() style, now might be the right
>> time to change it, although it may already be too late depending upon how
>> broadly pool is being used.

> How about adding getXxx() versions, implement the old ones in terms of
> them, and deprecate the old ones?

If we add getActiveCount()/getIdleCount() methods to the interface, it'll
break any custom implementations of ObjectPool that are out there.  (This is
of course why I want to add the base impls, then it'll only break anyone
who's implementing ObjectPool directly.)  I'd lean toward doing this now
rather than for a 2.0 release. I'm not even aware of anyone using a custom
ObjectPool impl, but this'll surely find them.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message