commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "otisg" <ot...@iVillage.com>
Subject Re: [dbcp] JDBC 3.0 and JDK 1.4
Date Wed, 13 Mar 2002 14:27:47 GMT
Heh, it won't. Where's my coffee...?

Sending the patches may still be goo, to save those with 1.4 some work
doing the same thing to compile DBCP under 1.4.

Otis
_______________________________________________________________
Get your own FREE email account at iVillage.com!
http://webmail.ivillage.com/

<-----Original Message----->

From: Andrus Adamchik
Sent: 3/13/2002 12:14:24 PM
To: commons-dev@jakarta.apache.org
Subject: Re: [dbcp] JDBC 3.0 and JDK 1.4

Question: if you added a method

public Savepoint setSavepoint(String name) throws SQLException

how is this going to compile with JSDK 1.3? java.sql.Savepoint was only 
added in 1.4




Lev Assinovsky wrote:
> Since JDK 1.4 includes JDBC 3.0
> I added all additional functions with a body like:
> {
> throw new SQLException("Not implemented.");
> }
> to be able to compile in JDK 1.4.


-- 
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
- Andrei (a.k.a. Andrus) Adamchik
Home of Cayenne - O/R Persistence Framework
http://objectstyle.org/cayenne/
email: andrus-jk at objectstyle dot org


--
To unsubscribe, e-mail: 
For additional commands, e-mail: 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message