commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Sanders" <ssand...@nextance.com>
Subject RE: [logging] makeNewLogInstance() method...
Date Thu, 31 Jan 2002 19:19:19 GMT
+1.  Go for it.

Scott

> -----Original Message-----
> From: James Strachan [mailto:james_strachan@yahoo.co.uk] 
> Sent: Thursday, January 31, 2002 11:16 AM
> To: Jakarta Commons Developers
> Subject: [logging] makeNewLogInstance() method...
> 
> 
> The LogSource has a static factory method called makeNewLogInstance();
> 
> How about following the naming conventions of JAXP and other 
> fairly recent libraries of just calling this newInstance()? 
> Its not a big deal, it just seems a bit less of a mouthful to 
> remember.
> 
> Also a question. From the code it appears that the 
> getInstance() method uses lazy construction and calls 
> makeNewLogInstance() if one does not already exist. If so, 
> should makeNewLogInstance() be a private/protected method?
> 
> i.e. should users always just call getInstance(). Or to put 
> that another way, when should users call makeNewLogInstance() 
> over getInstance().
> 
> James
> 
> 
> 
> 
> _________________________________________________________
> 
> Do You Yahoo!?
> 
> Get your free @yahoo.com address at http://mail.yahoo.com
> 
> 
> 
> 
> --
> To unsubscribe, e-mail:   
> <mailto:commons-dev-> unsubscribe@jakarta.apache.org>
> For 
> additional commands, 
> e-mail: <mailto:commons-dev-help@jakarta.apache.org>
> 
> 

--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message