commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Hammant <>
Subject Re: AltRMI - Proposal & request for help
Date Mon, 21 Jan 2002 15:57:13 GMT
James, Folks,

>> Very minor comment, how about renaming altrmi-tests.xml to be just
>> tests.xml. It saves some typing when running stuff. Maybe it could 
>> set a new
>> trend; build.xml is for building stuff and tests.xml is for various test
>> programs.
> Rename : will do.  It is separate primarily because there is an ant 
> task created which cannot be used in the build file that creates it :-(  

Done.  The targets have different names too now.  See the readme or do a 
-projecthelp on ant.

>> Another minor comment, some of the core APIs of AltRMI use Altrmi in the
>> interface names; how about removing them, since afterall the
>> classes/interfaces are in altrmi packages.
> True.  There is always a compromise between namespace on classnames.  
> My feeling is that "Connection" "Component" and "Document" are very 
> over used as class names and should definately be prefixed for futher 
> definitions. (Intellij's IDEA can be too suggestive for those).  In 
> short yes, Perhaps some of the Altrmi prefixes for class names should go.

About 10 things renamed now....

>> e.g.
>> AltrmiInvocationHandler -> InvocationHandler.
> Vote against as that's already used in the JDK.
>> AltrmiRequest -> Request
> No, because it's too simple a word.  It was the firsat thing to be 
> renamed from Request to AltrmiRequest.

But not those two... :-)

If enough people think it is best to purge Altrmi as prefic from all 
classes then I'll do it.  At the moment its 1 for, 1 against....


- Paul H

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message