commons-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From brit...@apache.org
Subject svn commit: r1749393 - in /commons/proper/cli/trunk/src/test/java/org/apache/commons/cli: BasicParserTest.java GnuParserTest.java PosixParserTest.java
Date Mon, 20 Jun 2016 19:41:00 GMT
Author: britter
Date: Mon Jun 20 19:41:00 2016
New Revision: 1749393

URL: http://svn.apache.org/viewvc?rev=1749393&view=rev
Log:
Ignore tests purposely left empty test bodies. Thanks to GitHub user august782. This also
closes #5 from GitHub.

Modified:
    commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/BasicParserTest.java
    commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/GnuParserTest.java
    commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/PosixParserTest.java

Modified: commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/BasicParserTest.java
URL: http://svn.apache.org/viewvc/commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/BasicParserTest.java?rev=1749393&r1=1749392&r2=1749393&view=diff
==============================================================================
--- commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/BasicParserTest.java (original)
+++ commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/BasicParserTest.java Mon
Jun 20 19:41:00 2016
@@ -18,6 +18,8 @@
 package org.apache.commons.cli;
 
 import org.junit.Before;
+import org.junit.Ignore;
+import org.junit.Test;
 
 @SuppressWarnings("deprecation") // tests some deprecated classes
 public class BasicParserTest extends ParserTestCase
@@ -29,147 +31,123 @@ public class BasicParserTest extends Par
         parser = new BasicParser();
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testDoubleDash2() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testLongWithoutEqualSingleDash() throws Exception
     {
-        // not supported by the BasicParser
     }
     
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testAmbiguousLongWithoutEqualSingleDash() throws Exception
     {
-        // not supported by the basicParser
     }
     
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser (CLI-184)")
     public void testNegativeOption() throws Exception
     {
-        // not supported by the BasicParser (CLI-184)
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testPropertiesOption1() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testPropertiesOption2() throws Exception
     {
-        // not supported by the BasicParser
     }    
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testShortWithEqual() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testShortWithoutEqual() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testLongWithEqualDoubleDash() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testLongWithEqualSingleDash() throws Exception
     {
-        // not supported by the BasicParser
     }
     
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testUnambiguousPartialLongOption1() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testUnambiguousPartialLongOption2() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testUnambiguousPartialLongOption3() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testUnambiguousPartialLongOption4() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testAmbiguousPartialLongOption1() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testAmbiguousPartialLongOption2() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testAmbiguousPartialLongOption3() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testAmbiguousPartialLongOption4() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testPartialLongOptionSingleDash() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testBursting() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testUnrecognizedOptionWithBursting() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testMissingArgWithBursting() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testStopBursting() throws Exception
     {
-        // not supported by the BasicParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the BasicParser")
     public void testStopBursting2() throws Exception
     {
-        // not supported by the BasicParser
     }
 }

Modified: commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/GnuParserTest.java
URL: http://svn.apache.org/viewvc/commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/GnuParserTest.java?rev=1749393&r1=1749392&r2=1749393&view=diff
==============================================================================
--- commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/GnuParserTest.java (original)
+++ commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/GnuParserTest.java Mon Jun
20 19:41:00 2016
@@ -18,6 +18,8 @@
 package org.apache.commons.cli;
 
 import org.junit.Before;
+import org.junit.Ignore;
+import org.junit.Test;
 
 @SuppressWarnings("deprecation") // tests some deprecated classes
 public class GnuParserTest extends ParserTestCase
@@ -29,129 +31,108 @@ public class GnuParserTest extends Parse
         parser = new GnuParser();
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testDoubleDash2() throws Exception
     {
-        // not supported by the GnuParser
     }
     
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testLongWithoutEqualSingleDash() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testAmbiguousLongWithoutEqualSingleDash() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser (CLI-184)")
     public void testNegativeOption() throws Exception
     {
-        // not supported by the GnuParser (CLI-184)
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testLongWithUnexpectedArgument1() throws Exception 
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testLongWithUnexpectedArgument2() throws Exception 
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testShortWithUnexpectedArgument() throws Exception 
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testUnambiguousPartialLongOption1() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testUnambiguousPartialLongOption2() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testUnambiguousPartialLongOption3() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testUnambiguousPartialLongOption4() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testAmbiguousPartialLongOption1() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testAmbiguousPartialLongOption2() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testAmbiguousPartialLongOption3() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testAmbiguousPartialLongOption4() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testPartialLongOptionSingleDash() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testBursting() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testUnrecognizedOptionWithBursting() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testMissingArgWithBursting() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testStopBursting() throws Exception
     {
-        // not supported by the GnuParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the GnuParser")
     public void testStopBursting2() throws Exception
     {
-        // not supported by the GnuParser
     }
 }

Modified: commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/PosixParserTest.java
URL: http://svn.apache.org/viewvc/commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/PosixParserTest.java?rev=1749393&r1=1749392&r2=1749393&view=diff
==============================================================================
--- commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/PosixParserTest.java (original)
+++ commons/proper/cli/trunk/src/test/java/org/apache/commons/cli/PosixParserTest.java Mon
Jun 20 19:41:00 2016
@@ -18,6 +18,8 @@
 package org.apache.commons.cli;
 
 import org.junit.Before;
+import org.junit.Ignore;
+import org.junit.Test;
 
 /**
  * Test case for the PosixParser.
@@ -32,57 +34,48 @@ public class PosixParserTest extends Par
         parser = new PosixParser();
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser")
     public void testDoubleDash2() throws Exception
     {
-        // not supported by the PosixParser
     }
     
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser")
     public void testLongWithoutEqualSingleDash() throws Exception
     {
-        // not supported by the PosixParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser")
     public void testAmbiguousLongWithoutEqualSingleDash() throws Exception
     {
-        // not supported by the PosixParser
     }
     
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser (CLI-184)")
     public void testNegativeOption() throws Exception
     {
-        // not supported by the PosixParser (CLI-184)
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser")
     public void testLongWithUnexpectedArgument1() throws Exception
     {
-        // not supported by the PosixParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser")
     public void testLongWithEqualSingleDash() throws Exception
     {
-        // not supported by the PosixParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser")
     public void testShortWithEqual() throws Exception
     {
-        // not supported by the PosixParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser")
     public void testUnambiguousPartialLongOption4() throws Exception
     {
-        // not supported by the PosixParser
     }
 
-    @Override
+    @Override @Test @Ignore("not supported by the PosixParser")
     public void testAmbiguousPartialLongOption4() throws Exception
     {
-        // not supported by the PosixParser
     }
 }



Mime
View raw message