commons-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ggreg...@apache.org
Subject svn commit: r1349351 - /commons/proper/io/trunk/src/changes/release-notes.vm
Date Tue, 12 Jun 2012 13:44:04 GMT
Author: ggregory
Date: Tue Jun 12 13:44:04 2012
New Revision: 1349351

URL: http://svn.apache.org/viewvc?rev=1349351&view=rev
Log:
Preparing release 2.4.

Modified:
    commons/proper/io/trunk/src/changes/release-notes.vm

Modified: commons/proper/io/trunk/src/changes/release-notes.vm
URL: http://svn.apache.org/viewvc/commons/proper/io/trunk/src/changes/release-notes.vm?rev=1349351&r1=1349350&r2=1349351&view=diff
==============================================================================
--- commons/proper/io/trunk/src/changes/release-notes.vm (original)
+++ commons/proper/io/trunk/src/changes/release-notes.vm Tue Jun 12 13:44:04 2012
@@ -147,6 +147,27 @@ Binary compatible: Yes.
 Source compatible: No, see the rare case in https://issues.apache.org/jira/browse/IO-318.
 Semantic compatible: No, see the rare case in https://issues.apache.org/jira/browse/IO-318.
 
+Commons IO 2.4 requires JDK 1.6 or later.
+Commons IO 2.3 requires JDK 1.6 or later.
+Commons IO 2.2 requires JDK 1.5 or later.
+Commons IO 1.4 requires JDK 1.3 or later.
+
+==============================================================================
+Apache Commons IO Version 2.3
+==============================================================================
+
+Changes in this version include:
+
+New features:
+o IO-322:  Add and use class Charsets. Thanks to ggregory. 
+o IO-321:  ByteOrderMark UTF_32LE is incorrect. Thanks to ggregory. 
+o IO-318:  Add Charset sister APIs to method that take a String charset name. Thanks to ggregory.

+
+Compatibility with 2.2 and 1.4:
+Binary compatible: Yes.
+Source compatible: No, see the rare case in https://issues.apache.org/jira/browse/IO-318.
+Semantic compatible: No, see the rare case in https://issues.apache.org/jira/browse/IO-318.
+
 Commons IO 2.3 requires JDK 1.6 or later.
 Commons IO 2.2 requires JDK 1.5 or later.
 Commons IO 1.4 requires JDK 1.3 or later.



Mime
View raw message