commons-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ggreg...@apache.org
Subject svn commit: r1296552 - /commons/proper/commons-build-plugin/trunk/pom.xml
Date Sat, 03 Mar 2012 01:51:09 GMT
Author: ggregory
Date: Sat Mar  3 01:51:09 2012
New Revision: 1296552

URL: http://svn.apache.org/viewvc?rev=1296552&view=rev
Log:
Now that we use maven-script-ant 2.2.1, which depends on org.apache.ant 1.7.1, we do not need
to ask for that version of Ant explicitely. Ant 1.7.0 is required for the "loadresource" Task.
Ant 1.7.1 is required for COMMONSSITE-35.

Modified:
    commons/proper/commons-build-plugin/trunk/pom.xml

Modified: commons/proper/commons-build-plugin/trunk/pom.xml
URL: http://svn.apache.org/viewvc/commons/proper/commons-build-plugin/trunk/pom.xml?rev=1296552&r1=1296551&r2=1296552&view=diff
==============================================================================
--- commons/proper/commons-build-plugin/trunk/pom.xml (original)
+++ commons/proper/commons-build-plugin/trunk/pom.xml Sat Mar  3 01:51:09 2012
@@ -66,32 +66,9 @@
             <groupId>org.apache.maven</groupId>
             <artifactId>maven-script-ant</artifactId>
             <version>2.2.1</version>
-            <!-- We need to exclude this artifact's dependency on Ant, -->
-            <!-- because it has a different groupId that the version of Ant -->
-            <!-- we want to use. -->
-            <exclusions>
-              <exclusion>
-                <groupId>ant</groupId>
-                <artifactId>ant</artifactId>
-              </exclusion>
-              <exclusion>
-                <groupId>ant</groupId>
-                <artifactId>ant-launcher</artifactId>
-              </exclusion>
-            </exclusions>
-        </dependency>
-
-        <!-- Ant 1.7.0+ required for the "loadresource" Task -->
-        <!-- Ant 1.7.1 required for COMMONSSITE-35 -->
-        <dependency>
-            <groupId>org.apache.ant</groupId>
-            <artifactId>ant</artifactId>
-            <version>1.7.1</version>
-        </dependency>
-        <dependency>
-            <groupId>org.apache.ant</groupId>
-            <artifactId>ant-launcher</artifactId>
-            <version>1.7.1</version>
+            <!-- maven-script-ant 2.2.1 depends on org.apache.ant 1.7.1 -->
+            <!-- Ant 1.7.0+ required for the "loadresource" Task -->
+            <!-- Ant 1.7.1 required for COMMONSSITE-35 -->            
         </dependency>
     </dependencies>
 



Mime
View raw message