commons-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From simonetrip...@apache.org
Subject svn commit: r1186033 - /commons/proper/digester/trunk/src/site/xdoc/index.xml
Date Wed, 19 Oct 2011 08:50:42 GMT
Author: simonetripodi
Date: Wed Oct 19 08:50:42 2011
New Revision: 1186033

URL: http://svn.apache.org/viewvc?rev=1186033&view=rev
Log:
added the Digester 3.1 release on home page

Modified:
    commons/proper/digester/trunk/src/site/xdoc/index.xml

Modified: commons/proper/digester/trunk/src/site/xdoc/index.xml
URL: http://svn.apache.org/viewvc/commons/proper/digester/trunk/src/site/xdoc/index.xml?rev=1186033&r1=1186032&r2=1186033&view=diff
==============================================================================
--- commons/proper/digester/trunk/src/site/xdoc/index.xml (original)
+++ commons/proper/digester/trunk/src/site/xdoc/index.xml Wed Oct 19 08:50:42 2011
@@ -68,6 +68,10 @@ download the files.
 </section>
 
 <section name="Releases">
+    <subsection name="Digester 3.1 Release (October 2011)">
+      <p>The Digester 3.1 release is a maintenance release that adds the <a href="./guide/async.html"></a>
feature.</p>
+    </subsection>
+
     <subsection name="Digester 3.0 Release (July 2011)">
       <p>
 The Digester 3.0 is an almost complete rewrite of the original Digester implementation, which
offers:
@@ -168,61 +172,6 @@ The recommended dependency set for Diges
 It is also possible to use Logging 1.0.x or BeanUtils 1.7.0 instead.
         </p>
     </subsection>
-
-    <subsection name='Digester 1.8.1 Release (January 2009)'>
-        <p>
-Digester 1.8.1 is a minor bugfix and maintenance release. Existing projects
-using Digester 1.8 are encouraged to upgrade to the 1.8.1 release. New projects
-are encouraged to use Digester 2.0, which requires JDK 1.5. See the release
-notes for more details.
-        </p>
-        <p>
-The dependencies for Digester 1.8.1 are identical to the dependencies for Digester 1.8.
-        </p>
-        <p>
-Digester 1.x versions had a dependency on
-<a href='http://commons.apache.org/collections'>Commons Collections</a>.
-The dependency can alternatively be satisfied by including the latest BeanUtils
-releases (1.7.0 or above) (which include the stable collections ArrayStack class
-necessary).
-        </p>
-        <p>
-The recommended dependency set for Digester 1.8.1 is:
-        </p>
-<table>
-<tr>
-<th colspan='3'>Recommended Dependency Set</th>
-</tr>
-<tr>
-<td>Digester</td>
-<td>+Logging 1.1.1</td>
-<td>+BeanUtils 1.8.0</td>
-</tr>
-</table>
-        <p>
-Other compatible dependency sets for Digester 1.8.1 can be summarized as follows:
-        </p>
-<table>
-<tr>
-<th colspan='4'>Compatible Dependency Sets</th>
-</tr>
-<tr>
-<td>Digester</td>
-<td>+Logging 1.1.x</td>
-<td>+BeanUtils 1.x</td>
-<td>+Collections 2.x</td>
-</tr>
-<tr>
-<td>Digester</td>
-<td>+Logging 1.1.x</td>
-<td>+BeanUtils 1.x</td>
-<td>+Collections 3.x</td>
-</tr>
-</table>
-        <p>
-It is also possible to use Logging 1.0.x or BeanUtils 1.7.0 instead.
-        </p>
-    </subsection>
     <subsection name='Downloading'>
  <ul>
   <li>The most recent release is available from apache mirrors via



Mime
View raw message