commons-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ohe...@apache.org
Subject svn commit: r895434 - /commons/proper/configuration/trunk/xdocs/dependencies.xml
Date Sun, 03 Jan 2010 16:10:55 GMT
Author: oheger
Date: Sun Jan  3 16:10:54 2010
New Revision: 895434

URL: http://svn.apache.org/viewvc?rev=895434&view=rev
Log:
[CONFIGURATION-402] Updated dependencies page.

Modified:
    commons/proper/configuration/trunk/xdocs/dependencies.xml

Modified: commons/proper/configuration/trunk/xdocs/dependencies.xml
URL: http://svn.apache.org/viewvc/commons/proper/configuration/trunk/xdocs/dependencies.xml?rev=895434&r1=895433&r2=895434&view=diff
==============================================================================
--- commons/proper/configuration/trunk/xdocs/dependencies.xml (original)
+++ commons/proper/configuration/trunk/xdocs/dependencies.xml Sun Jan  3 16:10:54 2010
@@ -28,6 +28,9 @@
         <section name="Runtime dependencies">
 
             <p>
+              Commons Configuration requires Java 1.4 or later.
+            </p>
+            <p>
               In the maven POM a lot of dependencies are declared. These are all
               needed during compile time. On runtime however you only need to
               add the dependencies to your classpath that are required by the
@@ -47,7 +50,6 @@
                     <tr>
                         <td>Core</td>
                         <td>
-                            Java 1.3<br/>
                             commons-collections<br/>
                             commons-lang<br/>
                             commons-logging
@@ -58,27 +60,25 @@
                         <td>
                             commons-digester<br/>
                             commons-beanutils<br/>
-                            Java 1.4 or xml-apis
                         </td>
                     </tr>
                     <tr>
                         <td>DefaultConfigurationBuilder</td>
                         <td>
                             commons-beanutils<br/>
-                            Java 1.4 or (xml-apis + xerces + xalan)
                         </td>
                     </tr>
                     <tr>
                         <td>DatabaseConfiguration</td>
-                        <td>JDBC 3.0 (Java 1.4 or jdbc2_0-stdext.jar)</td>
+                        <td>JDBC 3.0 (shipped with Java 1.4)</td>
                     </tr>
                     <tr>
                         <td>XMLConfiguration</td>
-                        <td>Java 1.4 or (xml-apis + xerces + xalan)</td>
+                        <td>see notes about XML processing</td>
                     </tr>
                     <tr>
                         <td>XMLPropertiesConfiguration</td>
-                        <td>Java 1.4 or (xml-apis + xerces)</td>
+                        <td>see notes about XML processing</td>
                     </tr>
 
                     <tr>
@@ -89,7 +89,7 @@
                         <td>XMLPropertyListConfiguration</td>
                         <td>
                             commons-codec<br/>
-                            Java 1.4 or xml-apis
+                            see notes about XML processing
                         </td>
                     </tr>
                     <tr>
@@ -108,6 +108,10 @@
                         <td>CatalogResolver</td>
                         <td>xml-resolver</td>
                     </tr>
+                    <tr>
+                        <td>Web configurations</td>
+                        <td>servlet-api</td>
+                    </tr>
                 </tbody>
             </table>
 
@@ -148,7 +152,7 @@
                     </tr>
                     <tr>
                       <td>commons-beanutils</td>
-                      <td>1.7.0, 1.8.0</td>
+                      <td>1.7.0, 1.8.0, 1.8.2</td>
                     </tr>
                     <tr>
                       <td>commons-codec</td>
@@ -166,19 +170,16 @@
                 </table>
                 </li>
                 <li>
-                  In Java versions before 1.4 XML support is not integrated. To
-                  make use of components that require XML processing you need
-                  to add a suitable replacement. We used 
-                  <a href="http://xml.apache.org/xerces2-j/">Xerces 2.2.1</a>,
-                  <a href="http://xml.apache.org/xalan-j/">Xalan 2.7.0</a>, and
-                  <a href="http://xml.apache.org/commons/">XML APIs 2.0.2</a>.
-                  Version 2.7.0 of Xalan seems to cause some problems in a few
-                  of our JUnit tests (a <code>java.lang.NoSuchMethodError</code>
-                  is thrown when a SAX data source is to be transformed into a
-                  DOM result). With version 2.6.0 these problems do not occur.
-                  In both cases the error happened only in test code; the actual
-                  code was not affected. But if you face a similar problem with
-                  Xalan 2.7.0 it is worth trying the older version.
+                  Java 1.4 comes with XML support. If you use only standard
+                  features (e.g. loading XML documents with
+                  <code>XMLConfiguration</code>), no additional dependencies
are
+                  needed. However, some modern features like schema validation
+                  are not supported by the parser shipped with Java 1.4. On
+                  Java 1.5 or higher this is not a problem; here everything
+                  works out of the box. With Java 1.4 you need further libraries
+                  to make these advanced features working. We used
+                  <a href="http://xml.apache.org/xerces2-j/">Xerces 2.3.0</a>,
+                  and <a href="http://xml.apache.org/commons/">XML APIs 1.0.b2</a>.
                 </li>
               </ul>
             </p>



Mime
View raw message