commons-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pste...@apache.org
Subject svn commit: r886661 - /commons/proper/dbcp/trunk/README.txt
Date Thu, 03 Dec 2009 02:43:51 GMT
Author: psteitz
Date: Thu Dec  3 02:43:46 2009
New Revision: 886661

URL: http://svn.apache.org/viewvc?rev=886661&view=rev
Log:
Updated README.

Modified:
    commons/proper/dbcp/trunk/README.txt

Modified: commons/proper/dbcp/trunk/README.txt
URL: http://svn.apache.org/viewvc/commons/proper/dbcp/trunk/README.txt?rev=886661&r1=886660&r2=886661&view=diff
==============================================================================
--- commons/proper/dbcp/trunk/README.txt (original)
+++ commons/proper/dbcp/trunk/README.txt Thu Dec  3 02:43:46 2009
@@ -4,24 +4,28 @@
 Welcome to the DBCP component of the Apache Commons
 project (http://commons.apache.org). 
 
-DBCP uses Maven 1 (http://maven.apache.org) for build 
-process management. It is known to build with Maven 1.0.2,
-though other versions may also work. 
+DBCP uses Maven 2 (http://maven.apache.org) for build 
+process management. 
 
-To build DBCP using Maven, type "maven" at a command line prompt
+To build DBCP using Maven, type "mvn package" at a command line prompt
 from the top-level directory of the source distribution (the directory
-that contains the file named project.xml).
+that contains the file named pom.xml).
 
 DBCP can also be built using Ant from the build.xml file. 
 Locations of dependent jars for the Ant build need to be specified in 
 build.properties.  There is a build.properties.sample file included in the
 source distribution.
 
-The binary distribution was built using JDK 1.6.0_14. The Ant build includes
-conditional compilation to support building on JDK 1.3. 
+The 1.4 binary distribution was built using JDK 1.6.0_14. The Ant build includes
+conditional compilation to support building on JDK 1.4 or 1.5. 
 
-This release of JDBC compiles with and supports JDK 1.3 (JDBC 2.0),
-JDK 1.4-1.5 (JDBC 3.0) and JDK 1.6 (JDBC 4.0). 
+This release of JDBC compiles with and supports JDK 1.4-1.5 (JDBC 3.0)
+and JDK 1.6 (JDBC 4.0).  The 1.4 binary release requires JDK 1.6 (JDBC 4.0). 
+The 1.3 binary release was built from filtered versions of the same sources
+using JDK 1.5.  
+
+DBCP 1.4 binaries should be used by applications running under under JDK 1.6
+and DBCP 1.3 should be used when running under JDK 1.4 or 1.5.
 
 See http://commons.apache.org/dbcp/ for additional and 
 up-to-date information on Commons DBCP.



Mime
View raw message