commons-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bay...@apache.org
Subject svn commit: r637365 - in /commons/proper/lang/trunk: RELEASE-NOTES.txt xdocs/upgradeto2_4.xml
Date Sat, 15 Mar 2008 06:19:47 GMT
Author: bayard
Date: Fri Mar 14 23:19:46 2008
New Revision: 637365

URL: http://svn.apache.org/viewvc?rev=637365&view=rev
Log:
Noting the Java requirements in our release notes

Modified:
    commons/proper/lang/trunk/RELEASE-NOTES.txt
    commons/proper/lang/trunk/xdocs/upgradeto2_4.xml

Modified: commons/proper/lang/trunk/RELEASE-NOTES.txt
URL: http://svn.apache.org/viewvc/commons/proper/lang/trunk/RELEASE-NOTES.txt?rev=637365&r1=637364&r2=637365&view=diff
==============================================================================
--- commons/proper/lang/trunk/RELEASE-NOTES.txt (original)
+++ commons/proper/lang/trunk/RELEASE-NOTES.txt Fri Mar 14 23:19:46 2008
@@ -10,6 +10,10 @@
 This document contains the release notes for the 2.4 version of Apache Commons Lang.
 Commons Lang is a set of utility functions and reusable components that should be of use
in any Java environment.
 
+Lang 2.4 no longer attempts to target the Java 1.1 environment and now targets Java 1.2.
While previous versions 
+were built for 1.1, some parts were using projects that were only available in 1.2, and the
Enum class had 
+become dependent on Java 1.3. 
+
 INCOMPATIBLE CHANGES WITH VERSION 2.3:
 
 - None

Modified: commons/proper/lang/trunk/xdocs/upgradeto2_4.xml
URL: http://svn.apache.org/viewvc/commons/proper/lang/trunk/xdocs/upgradeto2_4.xml?rev=637365&r1=637364&r2=637365&view=diff
==============================================================================
--- commons/proper/lang/trunk/xdocs/upgradeto2_4.xml (original)
+++ commons/proper/lang/trunk/xdocs/upgradeto2_4.xml Fri Mar 14 23:19:46 2008
@@ -32,6 +32,10 @@
 This document contains the release notes for the 2.4 version of Apache Commons Lang.
 Commons Lang is a set of utility functions and reusable components that should be of use
in any Java environment.
 
+Lang 2.4 no longer attempts to target the Java 1.1 environment and now targets Java 1.2.
While previous versions 
+were built for 1.1, some parts were using projects that were only available in 1.2, and the
Enum class had 
+become dependent on Java 1.3. 
+
 INCOMPATIBLE CHANGES WITH VERSION 2.3:
 
 - None



Mime
View raw message