cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <m...@digikartta.net>
Subject more encoding problems
Date Thu, 20 Sep 2012 07:22:54 GMT

 Hi,
 C2.11, I moved my app from one server to another, which resulted some 
 pages to broke that is scands won't encode properly.
 I have this in my sitemap:

 <map:match pattern="linkki/html/*">
 <map:generate src="cocoon:/linkki/{1}" type="text">
 </map:generate>
 <!--<map:transform type="xslt" src="linkki.xslt"/>-->
 <map:serialize type="text">
 </map:serialize>
 </map:match>
 
 <map:match pattern="linkki/*">
 <map:read type="databasereader" src="0" mime-type="text/plain">
 <!-- option sitemap parameters -->
 <map:parameter name="table" value="arvot"/>
 <map:parameter name="image" value="arvo_varchar"/>
 <map:parameter name="key" value="fake"/>
 <map:parameter name="where" value="id={1}"/>
 </map:read>
 </map:match>

 You can try this out:
 Old server
 http://77.240.23.91/cocoon/palaute_app/linkki/841 works
 http://77.240.23.91/cocoon/palaute_app/linkki/html/841 works
 New server
 http://88.148.163.59/cocoon/palaute_app/linkki/1059 works
 http://88.148.163.59/cocoon/palaute_app/linkki/html/1059 doesn't work 
 !!

 Any thoughts?
 I have tried a lot of things without success.

 - mika -

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message