cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robby Pelssers <Robby.Pelss...@nxp.com>
Subject RE: How to build cocoon 2.2 from source for debugging
Date Tue, 10 Jul 2012 10:57:47 GMT
You can also change the problematic pom’s to point to the correct parent pom.xml

  <parent>
    <groupId>org.apache.cocoon</groupId>
    <artifactId>cocoon</artifactId>
    <version>10-SNAPSHOT</version>  --> this is currently 6-SNAPSHOT
    <relativePath>../parent</relativePath>
  </parent>

@Francesco, can you confirm this?  I guess we should fix this in trunk in that case.

Robby


[ERROR] The build could not read 7 projects -> [Help 1]
[ERROR]
[ERROR]   The project org.apache.cocoon:cocoon-blocks-modules:6-SNAPSHOT (C:\development\workspaces\cocoon22\trunk\blocks\pom.xml)
has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact org.apache.cocoon:cocoon:pom:6-SNAPSHOT
and 'parent.relativePath' points at wrong local POM @ line 24, co
lumn 11 -> [Help 2]
[ERROR]
[ERROR]   The project org.apache.cocoon:cocoon-commons-modules:2-SNAPSHOT (C:\development\workspaces\cocoon22\trunk\commons\pom.xml)
has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact org.apache.cocoon:cocoon:pom:6-SNAPSHOT
and 'parent.relativePath' points at wrong local POM @ line 27, co
lumn 11 -> [Help 2]
[ERROR]
[ERROR]   The project org.apache.cocoon:cocoon-core-modules:6-SNAPSHOT (C:\development\workspaces\cocoon22\trunk\core\pom.xml)
has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact org.apache.cocoon:cocoon:pom:6-SNAPSHOT
and 'parent.relativePath' points at wrong local POM @ line 25, co
lumn 11 -> [Help 2]
[ERROR]
[ERROR]   The project org.apache.cocoon:cocoon-dists-modules:2-SNAPSHOT (C:\development\workspaces\cocoon22\trunk\dists\pom.xml)
has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact org.apache.cocoon:cocoon:pom:6-SNAPSHOT
and 'parent.relativePath' points at wrong local POM @ line 26, co
lumn 11 -> [Help 2]
[ERROR]
[ERROR]   The project org.apache.cocoon:cocoon-servlet-service-components:1.1.0-SNAPSHOT (C:\development\workspaces\cocoon22\trunk\core\cocoon-servlet-service\cocoon-se
rvlet-service-components\pom.xml) has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact org.apache.cocoon:cocoon:pom:6-SNAPSHOT
and 'parent.relativePath' points at wrong local POM @ line 24, co
lumn 11 -> [Help 2]
[ERROR]
[ERROR]   The project org.apache.cocoon:cocoon-servlet-service-components-sample:1.0.0-SNAPSHOT
(C:\development\workspaces\cocoon22\trunk\core\cocoon-servlet-service\co
coon-servlet-service-components-sample\pom.xml) has 1 error
[ERROR]     Non-resolvable parent POM: Could not find artifact org.apache.cocoon:cocoon:pom:6-SNAPSHOT
and 'parent.relativePath' points at wrong local POM @ line 23, co
lumn 11 -> [Help 2]
[ERROR]
[ERROR]   The project org.apache.cocoon:cocoon-project:1 (c:\development\workspaces\cocoon22\trunk\pom.xml)
has 1 error
[ERROR]     Child module c:\development\workspaces\cocoon22\trunk\subprojects\pom.xml of c:\development\workspaces\cocoon22\trunk\pom.xml
does not exist
[ERROR]

From: Francesco Chicchiriccò [mailto:ilgrosso@apache.org]
Sent: Tuesday, July 10, 2012 10:48 AM
To: users@cocoon.apache.org
Subject: Re: How to build cocoon 2.2 from source for debugging

Hi,
you shouldn't need to build 2.2 artifacts yourself, just use the provided maven dependencies
as suggested.
Could you please describe your use case in order to understand whether you absolutely need
to build the 2.2 source tree?

Regards.

On 10/07/2012 10:42, Huib Verwey wrote:
Hi Joel,

i had the same troubles as well, asked about it in the mailing as well, nothing changed apparently.
It looks like a mess, which is strange. I got everything working in the end, but the easiest
is to just add dependencies and don't try to compile everything yourself. If you
must you must, but I recommend against it. I hope you'll get away with not debugging the Cocoon
source code.
Hartelijke groet,

Huib.

Verstuurd vanaf mijn iPhone

Op 9 jul. 2012 om 22:07 heeft "Joel McConaughy" <joelmcconaughy@gmail.com<mailto:joelmcconaughy@gmail.com>>
het volgende geschreven:
Unfortunately I am working on an app built on cocoon 2.2 so need to use that version.  Thanks
for the quick reply though!

On Mon, Jul 9, 2012 at 1:00 PM, Reyes, Rafael <Rafael.Reyes@tigo.com.co<mailto:Rafael.Reyes@tigo.com.co>>
wrote:
Hi joel, i had the same trouble when i began with cocoon but I recommend that you download
the cocoon`s .war proyect, in google you can find this file with the name of cocoon 2.1.6
.war, after, you should to put this in the apache’s server deploying the proyect, clean
some parts of the proyect and everything its going to be all right.

--

Francesco Chicchiriccò



ASF Member, Apache Cocoon PMC and Apache Syncope PPMC Member

http://people.apache.org/~ilgrosso/
Mime
View raw message