cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Huttar <lars_hut...@sil.org>
Subject SOLVED (Re: maven problem with https: RSA premaster secret error)
Date Thu, 22 Mar 2012 20:36:00 GMT
OK, I was able to solve this.
When I typed "java -version" at the command line, it told me 1.6.0_31, 
so I thought I was running the latest.
But when I later looked at the JAVA_HOME env var, which maven uses, it 
pointed to an old 1.5.0 JDK.
One I pointed it to a newer 1.6.0_31 jdk, mvn ran fine.

Regards,
Lars


On 3/22/2012 12:24 PM, Lars Huttar wrote:
> Hi all,
> I'm sorry if this is off-topic, but I've googled the maven mailing 
> lists for this and found nothing.
> (http://maven.markmail.org/search/?q=rsa+premaster+secret+error)
>
> I was able to run maven (and thus use C3) on my development desktop 
> machine (running Windows 7).
> But when I tried running maven on another machine, I got the following 
> mysterious error output:
>
> D:\Apache Group\c3>mvn -X -e archetype:generate 
> -DarchetypeGroupId=org.apache.cocoon.archetype-parent 
> -DarchetypeArtifactId=cocoon-archetype-parent 
> -DarchetypeVersion=3.0.0-beta-1-SNAPSHOT -DgroupId=org.sil 
> -DartifactId=theParent -Dversion=1.0-SNAPSHOT 
> -DarchetypeRepository=https://repository.apache.org/content/repositories/snapshots/
>
> ...
> [INFO] Archetype defined by properties
> Downloading: 
> https://repository.apache.org/content/repositories/snapshots/org/ap
> ache/cocoon/archetype-parent/cocoon-archetype-parent/3.0.0-beta-1-SNAPSHOT/maven 
>
> -metadata.xml
> [WARNING] Could not transfer metadata 
> org.apache.cocoon.archetype-parent:cocoon-
> archetype-parent:3.0.0-beta-1-SNAPSHOT/maven-metadata.xml from/to 
> cocoon-archety
> pe-parent-repo 
> (https://repository.apache.org/content/repositories/snapshots/):
> Error transferring file: RSA premaster secret error
>
> I've googled around other places and found advice to the effect that 
> something is "stuffing up the child JVM's bootclasspath in a way that 
> causes the crypto libraries to break".
> http://stackoverflow.com/questions/2152988/rsa-secret-premaster-error
> However I have no idea how to address that problem.
> Install a new version of Java and make sure its JRE is at the front of 
> the classpath?
>
> Is there a way to just tell maven not to use https?
> I tried changing the repo URL to use "http" instead of "https", but 
> that just gave me a bunch of checksum warnings and XML validation errors.
>
> Thanks,
> Lars
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message