cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeroen Reijn <j.re...@onehippo.com>
Subject Re: revelet not repsonding
Date Sun, 08 Jan 2012 21:32:20 GMT
Hi,

I'm a bit confused here. You're talking about a filter that traps
 /webiso-login, but it seems a to be a servlet according to the below
configuration.
The order of the url patterns in the web.xml is indeed important, so place
all cocoon related servlet matches at the end if you want it to end up in
the webiso-login first.

Next to that it's important for us to know in what kind of application
container you are experiencing this.

Cheers,

Jeroen

On Fri, Jan 6, 2012 at 12:17 AM, Blanco, Jose <blancoj@umich.edu> wrote:

> I am using cocoon and have the following servlet mappings:
>
>  <servlet-mapping>
>        <servlet-name>Cocoon</servlet-name>
>        <url-pattern>/*</url-pattern>
>    </servlet-mapping>
>
>  <servlet-mapping>
>    <servlet-name>webiso-login</servlet-name>
>    <url-pattern>/webiso-login</url-pattern>
>  </servlet-mapping>
>
>    <servlet-mapping>
>        <servlet-name>Cocoon</servlet-name>
>        <url-pattern>*.jsp</url-pattern>
>    </servlet-mapping>
>
>    <servlet-mapping>
>        <servlet-name>Cocoon</servlet-name>
>        <url-pattern>*.html</url-pattern>
>    </servlet-mapping>
>
> I have a filter that traps for /webiso-login and the filter seems to be
> getting activated just fine, but when it is done I'm expecting it to go the
> servlet file, but it's not getting there.  Does my setup make sense?
>
> Thank you!
> Jose
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>


-- 
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com

Mime
View raw message