cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathaniel, Alfred" <Alfred.Nathan...@six-group.com>
Subject [C3] User survey on increase of minimum Java version to 1.6.0 for Cocoon3
Date Fri, 05 Aug 2011 13:41:59 GMT
Dear Cocooneers,

On the dev list we have been discussing whether to increase
the minimum Java version required for building and running
Cocoon3 (C3) from currently 1.5.0 (Java5) to 1.6.0 (Java6).

C3 is a green-field reimplementation of the Cocoon pipeline concept.
Thanks to the efforts of Reinhold Pötz and many others, C3 has now
already enough functionality implemented to be useful for certain
application types.

Java5 has been declared end-of-life in Oct 2009 with extended
support until 2015.  Java6 has been available since Dec 2006.

Given the choice you should certainly prefer to run Cocoon on Java6
to profit from its performance improvements.  For developers Java6
also offers a new features.

In fact, C3 developers usually use Java6 telling it to behave like
Java5.  When not careful the odd Java6-ism can sneak into the codebase.
That breaks the backwards compatibility when deployed on real Java5.

These are all solvable problems but a bit of a hassle draining the
scarce resources we can devote to the improvements of C3.  Therefore
the proposal to make Java6 the minimum version required for C3.

But we care about our fellow Cocoon aficionados and don't want to
leave anyone behind.  

Therefore this user survey:

If you are using C3 or seriously considering to use C3 in a Java5
environment without hope to upgrade to Java6, please speak up.

NB Cocoon 2.1 and Cocoon 2.2 is not concerned in this discussion.

Cheers, Alfred.

The content of this e-mail is intended only for the confidential use of the person addressed.

If you are not the intended recipient, please notify the sender and delete this e-mail immediately.
Thank you.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message