cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fawzib Rojas <f_ro...@spectron-msim.com>
Subject Re: configuring FOP NG for Cocoon2.2
Date Tue, 01 Mar 2011 13:13:16 GMT
AFAIK the cocoon-fop-ng-impl in the repositories is for cocoon 2.1 (It 
didnt work for me). I made a new version of the cocoon-fop-ng-impl and a 
new block cocoon-batik-ng-impl. Both seem to be working for me. The fop 
block uses fop-1.0, batik block uses batik-1.7.

You can get it from http://www.megaupload.com/?d=KUCDZ3XE , hope it 
works for you.

Faw

On 3/1/2011 6:15 AM, Robby Pelssers wrote:
> Hi all,
>
> I was wondering if someone had some notes on configuring  the org.apache.cocoon.blocks.fop.FOPNGSerializer.
>
> I found following page 'FOP and Embedding Fonts' at http://cocoon.apache.org/2.2/blocks/fop/1.0/1225_1_1.html
but it looks written for Cocoon2.1.x.
>
> E.g.
> $ cd %PATH_TO_COCOON%\lib  does not really apply in my case since Cocoon2.2 uses maven
and I don't have a cocoon lib folder unless I switch to using the target (build) folder of
my cocoon maven project.
>
> And the configuration file does not really match a configuration file of FOP1.0.
>
> <configuration>
>    <fonts>
>      <font metrics-file="D:/fop-fonts/arial.ttf.xml"
>      ...
>    </fonts>
> </configuration>
>
> Any help or usefull pointers are appreciated.
>
> Cheers,
> Robby Pelssers
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message