cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeroen Reijn <j.re...@onehippo.com>
Subject Re: Flash .swf in Cocoon 2.1.11
Date Wed, 05 Jan 2011 08:48:25 GMT
To me it seems like that you pointed at the problem. His script had
the parameter:

  'play', 'false'

so I guess that must be it, since the flash movie by itself apparently
has play (true) by default, since the movie started when you requested
only the swf. So there is probably an issue with the invocation of the
flash movie?

Jeroen


On Mon, Dec 13, 2010 at 7:59 AM, Jos Snellings <Jos.Snellings@pandora.be> wrote:
> Nice to hear that, Peter!
> Has anyone on this list an idea why it works now?
>
> cheers,
> Jos
>
> On 12/13/2010 07:30 AM, Peter Sparkes wrote:
>
> Thanks all for your help. I have now got it working. I had been using the
> following.
>
> <script language="JavaScript" type="text/javascript">
>     AC_FL_RunContent(
>         'codebase',
> 'http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=10,0,0,0',
>         'width', '680',
>         'height', '611',
>         'src', 'plan-de-pistes-bernex-v3',
>         'quality', 'high',
>         'pluginspage', 'http://www.adobe.com/go/getflashplayer',
>         'align', 'middle',
>         'play', 'false',
>         'loop', 'false',
>         'scale', 'showall',
>         'wmode', 'window',
>         'devicefont', 'false',
>         'id', 'plan-de-pistes-bernex-v3',
>         'bgcolor', '#ffffff',
>         'name', 'plan-de-pistes-bernex-v3',
>         'menu', 'true',
>         'allowFullScreen', 'false',
>         'allowScriptAccess','sameDomain',
>         'movie', 'plan-de-pistes-bernex-v3.swf',
>         'salign', ''
>         ); //end AC code
> </script>
>
> <noscript>
>     <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
> codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=10,0,0,0"
>     width="680" height="611" id="plan-de-pistes-bernex-v3"
> align="middle"><param name="allowScriptAccess" value="sameDomain" />
>     <param name="allowFullScreen" value="false" />
>     <param name="movie" value="plan-de-pistes-bernex-v3.swf" /><param
> name="quality" value="high" />
>     <param name="bgcolor" value="#ffffff" />
>     <embed src="plan-de-pistes-bernex-v3.swf" quality="high"
> bgcolor="#ffffff" width="580" height="611" name="plan-de-pistes-bernex-v3"
>     align="middle" allowScriptAccess="sameDomain" allowFullScreen="false"
> type="application/x-shockwave-flash"
> pluginspage="http://www.adobe.com/go/getflashplayer" />
>     </object>
> </noscript>
>
>
> I removed AC_FL_RunContent() and the noscript tags and now it works
>
> Regards
>
> Peter
>
> Hi Peter,
>
> Your page is ok, the element says "movie not loaded".  It looks to me like
> your problem is not cocoon related.
> I have a similar flash on a site.
> It has the parameter "play".
> Here is a sample:  (classid not right).
>
> <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
> codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0"
> WIDTH="460" HEIGHT="345">
>
>                                     <PARAM NAME="movie"
> VALUE="images/plan-de-pistes-bernex-v3.swf">
>                                     <PARAM NAME="quality" VALUE="high">
>                                     <PARAM NAME="bgcolor" VALUE="#FFFFFF">
>                                     <PARAM NAME="play" value="true">
>                                     <EMBED
> src="images/plan-de-pistes-bernex-v3.swf" quality="high" bgcolor="#FFFFFF"
> WIDTH="460" HEIGHT="345" TYPE="application/x-shockwave-flash"
> PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></EMBED></OBJECT
>
> Hope it helps.
>
> Jos
>
>
>
> On 12/07/2010 04:22 PM, Peter Sparkes wrote:
>
> Thanks Jasha,
>
> The html page displays correctly, except that the  .swf file is not
> displayed, see http://www.chezmuta.com/flashTest.htm. However,
> http://www.chezmuta.com/images/plan-de-pistes-bernex-v3.swf displays the
> .swf correctly. The browser source page for flashTest.htm appears correct.
>
> In my sitemap.xmap file I have
>
> <map:match pattern="images/*.swf">
>                 <map:read mime-type="application/x-shockwave-flash"
> src="resources/images/{1}.swf"/>
> </map:match>
>
> Regards
>
> Peter
>
>
> On 7 December 2010 13:49, Peter Sparkes <peter@didm.co.uk> wrote:
>>
>> Hi,
>>
>> I am trying, without success, to display a flash .swf files using Cocoon
>> 2.1.11
>>
>> Help please
>>
>> Peter
>>
> What's the problem? Is it the HTML or do you see 404-not found responses for
> certain resources that have anything to do with the swf? Providing more
> information leads more likely to a solution ;)
> Jasha Joachimsthal
>
> j.joachimsthal@onehippo.com - jasha@apache.org
>
> Hippo
> Europe   •   Amsterdam  Oosteinde 11  •  1017 WT Amsterdam  •  +31 (0)20
522
> 4466
> USA   •   San Francisco  755 Baywood Drive Second Floor  •  Petaluma CA
> 94954   •  +1 877 414 4776 (toll free)
> Canada  •   Montréal  5369 Boulevard St-Laurent #430  •  Montréal QC H2T
1S5
>  •  +1 (514) 316 8966
> www.onehippo.com  •  www.onehippo.org  •  info@onehippo.com
>
>
>
>
>
>



-- 
Hippo
----------------------------------------------------------------------------------------------
Europe  •  Amsterdam  Oosteinde 11  •  1017 WT Amsterdam  •  +31 (0)20 522 4466
USA  • 755 Baywood Drive Second Floor  •  Petaluma CA. 94954
•  +1 877 414-4776 (toll free)
Canada    •   Montréal  5369 Boulevard St-Laurent #430 •  Montréal QC
H2T 1S5  •  +1 (514) 316 8966
----------------------------------------------------------------------------------------------
www.onehippo.com  •  www.onehippo.org  •  info@onehippo.com
----------------------------------------------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message