cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hugh Sparks" <h...@csparks.com>
Subject Re: [C3] Building and running cocoon-sample
Date Fri, 14 May 2010 17:04:52 GMT
> ....
> The problem is fixed in trunk. It's related with the Spring 3.0 upgrade.
> Since the Cocoon Maven plugin is located in trunk, you have to build 2.2
> first (http://svn.apache.org/repos/asf/cocoon/trunk). Or you wait for
> the release (http://markmail.org/message/p3dqozgswocsojie).
> 
> Alternatively you can set the version of all referenced Spring
> dependencies to 2.5.6 in your project POM.

Thanks for the prompt reply!

I created a cocoon22 directory and checked out:

    http://svn.apache.org/repos/asf/cocoon/trunk 

In that directory, I ran "mvn clean install".
To test this, I went into core/cocoon-webapp and ran "mvn jetty:run"
The samples worked fine.

Next, I created a "cocoon3" directory and checked out:

    http://svn.apache.org/repos/asf/cocoon/cocoon3/trunk

In that directory I performed: "mvn clean install".
Then in the cocoon-sample directory I ran "mvn jetty:run".
I still get:

java.lang.AbstractMethodError: 
    org.apache.cocoon.tools.rcl.springreloader.SynchronizedConfigureableWebApplicationContext.setId
    ...

I happened to notice during the build of cocoon22 trunk that
the versions of spring-things seemed to be xxx-2.2.
Is that as expected?

I think I must be misunderstanding the phrase:

    "The problem is fixed in trunk..."

Perhaps I'm working with the wrong trunk?

Thanks again,

-Hugh


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message