cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark H. Wood" <mw...@IUPUI.Edu>
Subject Re: cocoon-block-deployment
Date Tue, 13 Apr 2010 13:38:12 GMT
On Tue, Apr 13, 2010 at 12:35:48PM +0200, Mathias Reem wrote:
> I want to use version 1.2.0 of cocoon-servlet-service-impl, because of
> the NPE fix that was added to that version. As c-s-s-i depends on
> cocoon-jnet (1.1.0) I've also added that jar to my libs. But now I've
> got the problem, that my Application won't start anymore, I get a MUE:
> 
> Invocation of init method failed; nested exception is
> java.net.MalformedURLException: The contextPath must be empty or start
> with '/' blockcontext:/websys

Oh, does that sound familiar.

See discussion of related issues in thread Message-ID:
<OF5C08EA92.4E89E0BC-ONC12576BE.0066A407-C12576BE.0066E91D@workflow.at>
on Tue, 2 Feb 2010 19:44:01 +0100, including the DSpace JIRA issue
noted there, which has extensive discussion.  I think perhaps forcing
the cocoon-linkrewriter-impl version addressed the supposedly
malformed contextPath, but that's just a guess -- as yet I'm far from
having my head wrapped around Cocoon's internals.

DSpace 1.6.0 has been out for a while now, uses
cocoon-servlet-service-impl:1.2.0 and cocoon-linkrewriter-impl:1.0.0,
and doesn't seem to be triggering any reports of these problems.

-- 
Mark H. Wood, Lead System Programmer   mwood@IUPUI.Edu
Balance your desire for bells and whistles with the reality that only a 
little more than 2 percent of world population has broadband.
	-- Ledford and Tyler, _Google Analytics 2.0_

Mime
View raw message