cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven D. Majewski" <sd...@virginia.edu>
Subject Re: problems with "Getting Started" 2.2 [was: Starting out with Cocoon 2.2]
Date Wed, 23 Sep 2009 18:22:50 GMT

I can create, 'mvn install' & 'mvn jetty:run' both myBlock1 & myBlock2.
When I try to connect the two blocks as in http://cocoon.apache.org/2.2/1291_1_1.html 
,
I get this error on either a jetty:run or an install:


myBlock1$ mvn jetty:run
[INFO] Scanning for projects...
[INFO]  
------------------------------------------------------------------------
[INFO] Building myBlock1
[INFO]    task-segment: [jetty:run]
[INFO]  
------------------------------------------------------------------------
[INFO] Preparing jetty:run
[INFO] [resources:resources {execution: default-resources}]
[WARNING] Using platform encoding (MacRoman actually) to copy filtered  
resources, i.e. build is platform dependent!
[INFO] Copying 9 resources
[INFO]  
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]  
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) edu.virginia.lib:myBlock2:jar:1.0-SNAPSHOT

   Try downloading the file manually from the project website.

   Then, install it using the command:
       mvn install:install-file -DgroupId=edu.virginia.lib - 
DartifactId=myBlock2 -Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/ 
path/to/file

   Alternatively, if you host your own repository you can deploy the  
file there:
       mvn deploy:deploy-file -DgroupId=edu.virginia.lib - 
DartifactId=myBlock2 -Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/ 
path/to/file -Durl=[url] -DrepositoryId=[id]

   Path to dependency:
   	1) edu.virginia.lib:myBlock1:jar:1.0.0
   	2) edu.virginia.lib:myBlock2:jar:1.0-SNAPSHOT

----------
1 required artifact is missing.

for artifact:
   edu.virginia.lib:myBlock1:jar:1.0.0

from the specified remote repositories:
   central (http://repo1.maven.org/maven2)



[INFO]  
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]  
------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Wed Sep 23 14:10:58 EDT 2009
[INFO] Final Memory: 17M/31M
[INFO]  
------------------------------------------------------------------------



If I comment out the myBlock2 dependency in myBlock1/pom.xml which I  
just added:


   <!--
     <dependency>
     	<groupId>edu.virginia.lib</groupId>
     	<artifactId>myBlock2</artifactId>
     	<version>1.0-SNAPSHOT</version>
     </dependency>
   -->

it will run again.

Does the order of the dependencies in the pom matter ?
( Eclipse is appending new ones at the end of <dependencies> )

Maybe I should try skipping the "Connect two blocks" part
and jump straight to trying to join them with the webapp.

-- Steve M. 





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message