cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Søren Krum <soren.k...@uninett.no>
Subject Re: ServerPagesGenerator in 2.2 ?!
Date Mon, 11 May 2009 08:37:43 GMT
Hi!

Now i tried out the ServerPageGenerator coming from cocoon:cocoon-xsp 
2.1.11 but if i try to run it in an environment which is based on 2.2, i 
get the following error:

Caused by:
java.lang.NoSuchFieldError: manager
at 
org.apache.cocoon.generation.ServerPagesGenerator.setup(ServerPagesGenerator.java:170)

That normally points to a version conflict (i.e. different versions of 
the class. Here it seems to be ServletGenerator, but that one has a 
manager, and it is protected, so the ServerPageGenerator should be able 
to see it

Anyone who has a idea what is going wrong?

Søren D. Krum



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message