cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hugh Sparks" <h...@csparks.com>
Subject Re: Cocoon 2.2 classic webapp
Date Wed, 13 Aug 2008 21:11:40 GMT
Many thanks to Reinhard Pötz!

To make this work with the current trunk, a few simple changes are needed:

pom.xml: Add a dependency for cocoon-servlet-service-components

    <parent>
        <groupId>org.apache.cocoon</groupId>
        <artifactId>cocoon-core-modules</artifactId>
        <version>6-SNAPSHOT</version>
    </parent>

    <dependency>
        <groupId>org.apache.cocoon</groupId>
        <artifactId>cocoon-core</artifactId>
    </dependency>

    <dependency>
        <groupId>org.apache.cocoon</groupId>
        <artifactId>cocoon-template-impl</artifactId>
    </dependency>

    <dependency>
        <groupId>org.apache.cocoon</groupId>
        <artifactId>cocoon-servlet-service-components</artifactId>
    </dependency>

web.xml: Add a listener for BlockDeploymentServletContextListener

    <listener>
        <description>Declare a context listener that installs all blocks.</description>
        <listener-class>org.apache.cocoon.blockdeployment.BlockDeploymentServletContextListener</listener-class>
    </listener>

I don't understand why these components should be required if they
aren't used, but this gets the webapp going without errors.

-Hugh Sparks, hugh@csparks.com



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message