cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hugh Sparks" <h...@csparks.com>
Subject Re: Cocoon 2.2 without tears
Date Fri, 15 Aug 2008 17:24:44 GMT
> Ken Starks writes:
> [...]
> I've had a second attempt at your 'Cocoon 2.2 without tears' webapp,
> but it isn't working for me.
> Reason: Cannot find parent: org.apache.cocoon:cocoon-core-modules for project:
> csparks.com:cocoon22:war:1.0 for project csparks.com:cocoon22:war:1.0

I'll try to get you going in this letter, but if this takes
any further correspondence, we should probably switch
to private email because I don't want to irritate users
who aren't interested in this topic.

I just tried the download myself and it worked for me.
There's evidently something missing in your local .m2
repository. I think the problem is with the parent element
in the pom. It looks like the cocoon-core-modules artifact
is not being maintained in the central maven repository
or I don't know how to use it properly.

Do you have Subversion installed? I keep a checkout of
the cocoon 2.2 trunk that I update and build every day.
I think that's why it works for me and not for you.

A quick fix is to checkout and build the cocoon 2.2 truck.
Then the reference to cocoon-core-modules 6-SNAPSHOT
will be correctly resolved.

Otherwise, you'll have to discard the parent element
from the pom and dig up a consistent set of version
elements for the individual dependences.

In light of your difficulty, I'll update my website
so others won't have this problem, but I'm not able
to do this immediately.

If you don't intend to use blocks at all, I like the cocoon classic
method recently published by Reinhard Pötz.
My write-up is for uses who want to combine open content
but keep the option of using blocks as well.

-Hugh Sparks


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message