cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Thenot <andre-li...@thenot.org>
Subject Re: Creating a parent POM
Date Thu, 24 Jul 2008 22:46:14 GMT
On Jun 28, 2008, at 14:15, Benjamin Boksa wrote:

> when trying to follow the part "Creating a parent pom" in the  
> "Deploying a Cocoon application" tutorial [1] I get the following  
> error:
<snip/>
> [INFO] Internal error in the plugin manager executing goal  
> 'org.apache.maven.plugins:maven-war-plugin:2.0.2:war': Unable to  
> find the mojo 'org.apache.maven.plugins:maven-war-plugin:2.0.2:war'  
> in the plugin 'org.apache.maven.plugins:maven-war-plugin'
> Component descriptor cannot be found in the component repository:  
> org.apache.maven.plugin.Mojoorg.apache.maven.plugins:maven-war- 
> plugin:2.0.2:war.

I've been getting the same error too. I was wondering if the 2.0.2  
version of maven-war-plugin was to blame so I tried changing the  
version to 2.0.1 in my webapp block but I noticed the message still  
refers to 2.0.2 despite running `mvn clean`. So either I'm not  
correctly cleaning my project or something else is including  
org.apache.maven.plugins:maven-war-plugin:2.0.2:war. Mysterious...

   Has anybody else successfully set up a parent POM for their cocoon  
project so that a single `mvn install` builds all the blocks and  
deploys a war in one step? I can write a Makefile but I'm trying to  
learn how to do things The Maven Way.

Any pointers are greatly appreciated.

A.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message