cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Starks <...@lampsacos.demon.co.uk>
Subject Re: RCL. Help needed with the rapid class reloader
Date Tue, 29 Jul 2008 17:43:00 GMT
Torsten Curdt wrote:
>> Yes, I shall at some stage look at how my eclipse setup could be 
>> improved. However, I
>> suspect that, for my present problem, it would be a red herring.
>
> No that exactly seems to be your problem. Fix that and you are good.
>
>> RCL is not supposed to depend on a particular IDE such as eclipse; it 
>> is supposed
>> to work even if you edit files in a simple text editor.
>
> These are two different things. And RCL does work with class files - 
> not source files. Still it does not depend on a particular IDE. It 
> also works with IDEA, Netbeans or whatever. It's just that someone 
> else is doing the compilation and the RCL will pick up the result.
>
> As said before. JCI could also do the compilation. But this is added 
> complexity that you usually don't need. I suggest you get the easy 
> part working first ;)
>
>> In fact, that is what i have been
>> doing today and RCL has still not been working.
>
> You are not providing it the updated class files.
>
>> If my understanding is correct:-
>> It is supposed to do a quick whip around of certain souce files, 
>> making some sort of
>> check-sum, and it is supposed to do so quite often. When the 
>> check-sum changes,
>> it is supposed to start an automatic rebuild.
>
> No you got it wrong. Again: it works with class files.
>
> You change your source file. Now you hit on save in Eclipse. That will 
> trigger the compilation of the class file. In other IDEs you might not 
> have the incremental build and you have to press "build". Then your 
> IDE will build the class file and write it (usually) to the target 
> directory. The RCL notices something has been updated and reloads that 
> part of your cocoon app.
>
> My suggestion:
>
> 1. close eclipse
> 2. rm -R target
> 3. mkdir target
> 4. start eclipse
> 5. project -> clean
> 6. make sure project -> build automatically is checked
> 7. you should not see any errors
> 8. run find target -name "*.class"
>
> You should then see all the class files in the target dir. If you have 
> pointed the RCL to that target dir everything should work like charm.
> If not check the project settings on the source tab for the output dir.
>
> cheers
> -- 
> Torsten
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>
>
OK I'll give it a shot.
As you suggested, it might be that my eclipse setup is wrong.  I expect 
the eclipse 'build' command doesn't know where
the target directory is supposed to be.

I have looked at the 'Run dialog' which is to 'create, manage, and run 
configurations' but I am rather overwhelmed by it.

It must be compiling _somewhere_ for goodness sake, because it will 
produce the .jar package under target, and install it
in my local maven repository.

So far, none of my variations have worked with RCL:  import as an 
'existing project'; import as a 'maven project'; create
as a maven project within eclipse. I think they have all worked otherwise.

As mentioned previously, Eclipse Navigator does not see the *.class 
files even after a refresh or a brand new import, when
I know they are there. It also does not see the .classpath and .project 
files. Is this bad?



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message