cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Jboss 5.0.0.CR1 / Cocoon.war deployment issue - java.lang.IllegalAccessError: class javax.xml.parsers.SecuritySupport12
Date Wed, 04 Jun 2008 02:44:43 GMT
On 03.06.2008 20:55, Andrew Madu wrote:

> I am in the process of migrating my application from 4.0.3SP1 to 
> 5.0.0.CR1, on Win XP SP1, and am receiving the following error message 
> in the server logs when placing my WAR (Cocoon 2.1.8) into the deploy 
> directory. It would seem that there is an issue concerning the 
> xml-apis.jar/xml-apis-1.3.04 files situated within 
> Cocoon.war/WEB-INF/lib(?):
> 
> [code]
> 2008-06-04 01:09:54,796 WARN  
> [org.jboss.detailed.classloader.ClassLoaderManager] (main) Unexpected 
> error during load of:javax.xml.parsers.SecuritySupport12
> java.lang.IllegalAccessError: class javax.xml.parsers.SecuritySupport12 
> cannot access its superclass javax.xml.parsers.SecuritySupport

The closest I got is [1]. From that I'd guess you should avoid to deploy 
the mentioned classes and to the webapp's WEB-INF/lib directory.

Joerg

[1] 
http://qaix.com/java-programming/30-567-jboss-3-tomcat-4-0-3-illegalaccesserror-read.shtml

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message