cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert La Ferla <robertlafe...@comcast.net>
Subject Re: java 1.5 and cocoon
Date Tue, 25 Mar 2008 01:03:22 GMT

On Mar 22, 2008, at 12:27 PM, Joerg Heinicke wrote:

> On 22.03.2008 11:07, Patrick Heiden wrote:
>
>>>> Some parts of my domainmodel rely on java-1.5 specific stuff  
>>>> like  Generics and so on. Within my first cocoon steps I don't  
>>>> have  changed the source=1.3 attribute and of course get the  
>>>> 'generics are  not supported in -source 1.3'-build-error. Is this  
>>>> the only thing I  have to change to use java 1.5?
>>> Depends on what you are using to build your project. In my ant   
>>> projects I have both 'source' and 'target' attributes set to 1.5.  
>>> See
>>> http://ant.apache.org/manual/CoreTasks/javac.html
>> I am using maven to build my project and cocoon 2.2 as my web-tier.  
>> I've read that it is also necessary to change some cocoon src-files  
>> wich use 'enum' as identifier because since 1.5 it is a keyword. Is  
>> this right? So what do I actually have to change when using 1.5 and  
>> cocoon 2.2?
>
> Nothing except for the build configs mentioned above. Cocoon is Java  
> 5 or even Java 6 compatible.

I think this is true for Cocoon 2.1 and above but not for 2.0 which  
has a package with "enum" in the namespace.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message