cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kai Mütz <kmu...@web.de>
Subject RE: Newer FOP to Cocoon 2.1.11
Date Wed, 13 Feb 2008 13:54:43 GMT
users-return-93940-kmuetz=web.de@cocoon.apache.org <> wrote:
> Hi,
>
> this is a question, I've been reading mails about a very long time,
> but haven't been still get a proper answer to it.
>
> So I want 0.9x or 1.xx or NG or whatever FOP to Cocoon 2.1.x because
> the
> 0.20.5 is so restricted. 0.94 would have all the features I need. So
> how it is done?
>
>  From where can I download a proper FOPxxyy.jar?

- Download FOP 0.94

http://xmlgraphics.apache.org/fop/download.html

Follow the link to a FOP Distribution mirror.

> What else do I have to do? I mean step by step; I am not an expert on
> these issues, just using the software.

- Download the Next Generation FOP Serializer (FOPNGSerializer.java)

http://svn.apache.org/repos/asf/cocoon/trunk/blocks/cocoon-fop/cocoon-fop-ng
-impl/src/main/java/org/apache/cocoon/blocks/fop/

- Compile it
- Put it in your classpath
- Replace the fop.jar in your cocoon installation
- Add xmlgraphics-commons-1.2.jar to your cocoon installation
- Disable the "old" FOPSerializer in your root sitemap
- Register the FOPNGSerializer in your sitemap

This works within my cocoon 2.1.8 installation.

Kai


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message