cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Stevens <insomniacpeng...@googlemail.com>
Subject Re: cocoon 2.2 & jsp... again)
Date Thu, 07 Feb 2008 01:02:42 GMT
nanomonk wrote:
> i have an error:
> javax.servlet.ServletException: org.apache.cocoon.ProcessingException:
> Exception
>  JSPGenerator.generate()
> ....
> Caused by: org.apache.avalon.framework.service.ServiceException: Component
> with 'org.apache.cocoon.components.jsp.JSPEngine' is not defined in this
> service manager. (Key='AvalonServiceManager')
> what doing "avalon" here? this project closed as I know...

That's the beauty of open source - just because a project is no longer 
active, that doesn't stop you using it.  It just means you'll have to 
fix any remaining bugs yourself, but at least that's possible since 
you've got the source...

> ----
> btw...just tell me can I use cocoon-jsp-2.1.9 for .jsp with parameters and
> how?

I'm confused - which Cocoon version are you using?  2.2 like the title 
says, or 2.1.9?  Or are you trying to use 2.1.9's JSP block from a 
2.2-based application?


Andy.
-- 
http://pseudoq.sourceforge.net/  Open source java Sudoku generator

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message