cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nacho Jiménez" <nacho.jime...@gmail.com>
Subject [Cocoon 2.2, Hibernate 3] Conflict in ehcache
Date Mon, 01 Oct 2007 14:43:09 GMT
Dear all,

I'm trying to migrate my Cocoon 2.1/Spring/Hibernate apps to Cocoon
2.2, and after a bit of banging my head against he wall, i finally
understood what's maven and how to create cocoon projects, etc.

I've created a cocoon 2.2 block with basic spring-hibernate
functionality, but when i try to "run" it into a jetty servlet
contanier (mvn jetty:run), all i get is a conflict between
ehcache-1.2.4, demanded by cocoon, and ehcache1.1, included by
hibernate:

Caused by: org.apache.maven.plugin.MojoExecutionException: There are
at least two artifacts with the ID 'ehcache':

ehcache:ehcache:jar:1.1:compile
    com.unmardedatos:eMarketing:jar:1.0-SNAPSHOT
    org.apache.cocoon:cocoon-core:jar:2.2.0-RC1
    org.apache.cocoon:cocoon-store-impl:jar:1.0.0-RC1
    net.sf.ehcache:ehcache:jar:1.2.4
ehcache:ehcache:jar:1.1:compile
    com.unmardedatos:eMarketing:jar:1.0-SNAPSHOT
    org.springframework:spring-hibernate3:jar:2.0-m4
    org.hibernate:hibernate:jar:3.1.2
    ehcache:ehcache:jar:1.1

What can I do to compile it?  I'm getting desperate here, so any help
will be greatly appreciated.

Thanks..

Nacho

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message