cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hugh Sparks" <h...@csparks.com>
Subject Cocoon 2.2 - Can't bulid block after cocoon update
Date Wed, 17 Oct 2007 10:00:20 GMT
I have a block that contains these dependencies:

    <dependency>
        <groupId>org.apache.cocoon</groupId>
        <artifactId>cocoon-databases-impl</artifactId>
        <version>1.0.0-RC3-SNAPSHOT</version>
    </dependency>

    <dependency>
        <groupId>org.apache.cocoon</groupId>
        <artifactId>cocoon-xmldb-impl</artifactId>
        <version>1.0.0-SNAPSHOT</version>
 </dependency>

I got the version numbers from the most recent cocoon 2.2 svn update.
(Is there a way to get rid of these version elements by somehow pointing
to my local .m2 repository? It appears that the cocoon block poms do this,
but I can figure out how it is configured for a block located elsewhere in
the filesystem.)

When I tried to build my block, these errors appear:

    [WARNING] POM for 'xmldb:xmldb-api:pom:20030701:compile' is invalid.
    It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM. 
for project
    xmldb:xmldb-api at

        blah_blah\.m2\repository\xmldb\xmldb-api\20030701\xmldb-ap

As a result, my block doesn't get a copy of the xindice stuff.
I think this pom used to work...

Next, I trashed my .m2/repository,  went into my cocoon 2.2
repository and did an svn update followed by mvn clean install -P allblocks.
The result was completely successful. At this point, I would expect
everything to be wonderful in my .m2 cache.

But now when I try to build my block, I get multiple components missing,
even though I just built all of cocoon 2.2:

Missing:
----------
1) org.apache.cocoon:cocoon-fop-impl:jar:1.0.0-RC3-SNAPSHOT
2) org.apache.cocoon:cocoon-xmldb-impl:jar:1.0.0-SNAPSHOT
3) org.apache.cocoon:cocoon-databases-impl:jar:1.0.0-RC3-SNAPSHOT

This seems unjust.

Thanks to all,

-Hugh Sparks


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message