cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven D. Majewski" <sd...@virginia.edu>
Subject Re: Help with Cocoon 2.2.x
Date Tue, 17 Jul 2007 22:43:04 GMT

On Jul 17, 2007, at 5:27 PM, Grzegorz Kossakowski wrote:

> Steven D. Majewski pisze:
>> On Jul 17, 2007, at 2:46 PM, Steven D. Majewski wrote:
>>> Caused by: org.gjt.xpp.XmlPullParserException: <![DOCTYPE  
>>> declarations not supported at line 33 and column 3 seen "...CDATA  
>>> #REQUIRED\n               class CDATA #REQUIRED\n>\n]"... (parser  
>>> state UNKNONW_EVENT (-1))
>> I tried cutting the DOCTYPE out of cocoon.roles and replacing it  
>> in the jar.
>> It got a bit farther this time -- I got this error page from  
>> http://localhost:8888/ :
>
> <snip/>
>
>> ------
>> I found this thread on cocoon-dev:  http://www.mail-archive.com/ 
>> dev@cocoon.apache.org/msg52300.html
>> so I tried deleting the DOCTYPE from both cocoon.roles and sitemap- 
>> language.xml and rebuilding with maven
>> but I now get a java.lang.NullPointerException ( and a few others  
>> are also logged on jetty startup. )
>
> Hmmm, it's all very weird. I use Cocoon every day on different Java  
> versions and OSes and never came across this problem.
> The only difference is that I don't use allblocks profile because I  
> don't need all blocks.
>
> I'll have a look into this tomorrow and will report my findings.  
> Thanks for your detailed reports!
>
>


I haven't yet really learned maven -- getting over that hurdle is  
what kept me from trying 2.2 earlier.
The README just says to do:

   $ mvn -Dmaven.test.skip=true -P allblocks install

and I don't know what other profiles are available.

But I just tried it without the "allblocks":

	$ mvn -Dmaven.test.skip=true install

and after 'mvn jetty:run' , I can connect to the welcome page
without error. Clicking on the samples link shows a pretty minimal
page with Template Block, AJAX Block, Forms Block and Core samples.

So "allblocks" does seem to make the difference!


BTW: When I tried simply: '$ mvn install'
it ran all of the tests and failed on something at the end,
but scanning back in the output, I mostly saw stack traces for
"...this_file_does_not_exist.txt doesn't exist." , which looks
like an expected result. Somewhere way back was a real failure:

Running org.apache.cocoon.generation.FileGeneratorTestCase
Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.161  
sec <<< FAILURE!



This is all with newer snapshot: cocoon_20070717162432.tar.gz

( I was about to try the patch referenced in
  http://www.mail-archive.com/dev@cocoon.apache.org/msg52317.html
   but it looks like the snapshot code's cocoon.roles already
   includes those mods. )



-- Steve Majewski




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message