cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lally Singh" <lally.si...@gmail.com>
Subject Re: Component with 'org.apache.cocoon.components.flow.Interpreter/javascript' is not defined
Date Fri, 04 May 2007 23:36:18 GMT
On 5/4/07, Grzegorz Kossakowski <gkossakowski@apache.org> wrote:
> Lally Singh pisze:
> > Latest version I could find, maven 2.0.6
>
> Yeah, Maven 2.0.6 will work fine.
>
> > I updated my POMs from the latest archetypes, and that error went
> > away, replaced with a few others.  I got through a few of them, only
> > stuck on a NullPointerException in Spring :-(
> >
> > Btw, the newest archetype poms don't have version #s in them, and
> > maven just spits them out.
>
> Can you show an example? I thought it's already fixed.
Sure.  This is what I have right now, from an SVN update of sometime
this or last week.  I updated again and there are version #s in them
again.  I was afraid Cocoon had moved to a dev version of maven that
used some other means of determining the version #

> > 2007-05-04 16:27:56.439::WARN:  Nested in
> > org.springframework.beans.factory.BeanDefinitionStoreException: Unable
> > to read spring configurations from classpath*:META-INF/cocoon/spring;
> > nested exception is
> > org.springframework.beans.factory.BeanDefinitionStoreException:
> > Unexpected exception parsing XML document from URL
> > [jar:file:/Users/lally/Work/School/GRA/IDDL/New_System/iddl_svn/ratlee/meval/trunk/whole/cocoonapp/target/cocoonapp-1.0-SNAPSHOT/WEB-INF/lib/qgenerator-1.0-SNAPSHOT.jar!/META-INF/cocoon/spring/block.xml];
>
> Can you show your block.xml file?
Attached.

Thanks for all your help!

-- 
H. Lally Singh
Ph.D. Candidate, Computer Science
Virginia Tech

Mime
View raw message