cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pieter Delmee <p.del...@elsto.nl>
Subject Re: Upload Widget HTML Page does not render
Date Tue, 24 Apr 2007 10:42:55 GMT
Steven Barrett wrote:
> I have tried using the upload widget which works well in my local Cocoon
> installation using 2.1.9 (windows)
> 
> However when the code is uploaded to my ISP's server also using 2.1.9
> (linux) the HTML page displayed in the browser appears blank. The source
> reveals that there is HTML content but it does not render correctly in the
> browser.
> 
> I am using Firefox 1.5.0.11 for both my local tests (which work) and for
> testing the deployed code at the ISP's server (which doesn't work).
> 
> Comparing the HTML generated from my local server to that generated by the
> ISP's server the markup does have differences.
> 
> The main ones are.
> 
> The page that doesn't work has <?xml version="1.0" encoding="ISO-8859-1"?>
> declared where as the working page does not.
> 
> I can get the non working page to render if the line.
> 
> <script src="resources/forms/htmlarea/htmlarea.js" type="text/javascript" />
> 
> .is changed to.
>  
> <script src="resources/forms/htmlarea/htmlarea.js" type="text/javascript" >
> </script>

I think the serializer causes the difference. The html serializer makes 
sure that script elements are written with a separate closing element. 
If you're using the xhtml serializer, then that's probably causing the 
difference.

Adding <omit-xml-declaration>yes</omit-xml-declaration> to the 
serializer configuration will prevent the <?xml ... element, but then 
you're not outputting xhtml anymore, so it's better to switch back to html.

Do you provide the serializer configuration yourself, or is it set by 
your ISP.


> 
> There are other differences between the files, like the inclusion ordering
> of some of the <script> tags. 
> 
> On the ISP's server I do see some log ERROR's that do not appear in my local
> installation like.
> 
> 19:28:42.952 EVENT  ERROR   (2007-04-21) 19:28.42:951   [sitemap.]
> (/inccom/fileupload/resources/dojo/dojo.js) PoolThread-4/ErrorHandlerHelper:
> Error during resolving of the input stream19:28:44.425 EVENT  ERROR
> (2007-04-21) 19:28.44:423   [sitemap.]
> (/inccom/fileupload/resources/forms/css/forms.css)
> PoolThread-4/ErrorHandlerHelper: Resource not found.
> 19:28:47.116 EVENT  ERROR   (2007-04-21) 19:28.47:115   [sitemap.]
> (/inccom/fileupload/resources/forms/css/forms-calendar.css)
> PoolThread-4/ErrorHandlerHelper: Error during resolving of the input stream

Check that the following pipe exists in /inccom/fileupload/sitemap.xmap

<map:match pattern="resources/*/**">
   <map:read src="resource://org/apache/cocoon/{1}/resources/{2}" />
</map:match>


> 
> Does anyone have any ideas and could help?
> 
> I can send through some specific code if required.
> 
> Thanks.
> Steve


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message