cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Java 6, Vista, or config problem?
Date Mon, 02 Apr 2007 19:43:19 GMT
On 02.04.2007 20:42, Julian wrote:

> I have been running Cocoon 2.1.2 just fine until a few days ago when
> I switched to Java 6 on Vista Business. I kept getting errors that appear
> to be related to caching. I then tried to update to Cocoon 2.1.10, but
> the same error is thrown. Anyone have any idea why the following error
> is thrown?

Hi Julian,

it's hard to guess what the actual error is. From what I understand it's 
completely unrelated to Cocoon, you should be able to reproduce the 
problem on the command line. When loading o.a.c.util.IOUtils it just 
tries to call the static method getInstance() on the class 
java.text.Collator:

static final Collator englishCollator = 
Collator.getInstance(Locale.ENGLISH);

It gets to the Sun internal class sun.text.normalizer.NormalizerImpl and 
fails while loading it (<clinit> is only the static part, even before a 
constructor). I guess there is no source code available for the Sun 
class, so you can't see what it is trying to do. This error might either 
be a bug in Java 6 or something specific for your environment - but as I 
said it should not be related to Cocoon.

Regards
Joerg

> 2007-04-02 14:25:31,283 [main] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/standard].loadOnStartup
at line 3958 - Servlet /standard threw load() exception
> java.lang.RuntimeException: could not locate data
>     at sun.text.normalizer.NormalizerImpl.<clinit>(NormalizerImpl.java:44)
>     at java.text.RBTableBuilder.build(RBTableBuilder.java:89)
>     at java.text.RBCollationTables.<init>(RBCollationTables.java:65)
>     at java.text.RuleBasedCollator.<init>(RuleBasedCollator.java:276)
>     at java.text.Collator.getInstance(Collator.java:251)
>     at org.apache.cocoon.util.IOUtils.<clinit>(IOUtils.java:173)
>     at org.apache.cocoon.servlet.CocoonServlet.init(CocoonServlet.java:445)

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message