cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Dockins <rdock...@tufts.edu>
Subject Workaround for Xalan bug?
Date Fri, 06 Apr 2007 19:08:57 GMT
I'm currently working on a web application using the eXist XML  
database (http://exist.sourceforge.net/), snapshot 1.1.1, which  
includes Cocoon (apparently version 2.1.7).  I have a problem where  
one of my stylesheets fails and returns an empty reply (ie, no bytes  
are sent to the browser).

I believe I've tracked down the problem.  Apparently under some  
circumstances, my stylesheet is tickling the following Xalan bug  
(http://issues.apache.org/jira/browse/XALANJ-1243).  The Xalan  
version that appears in the eXist distribution is version 2.7.0.

I understand that the base bug is upstream, but there doesn't appear  
to be a good patch for the Xalan problem (the bug is still open), so  
I wonder if there is a workaround.  I've run the stylesheet over the  
input data using a different XSLT processor which doesn't exhibit the  
problem, so I'm pretty sure its a Xalan problem.  This is my first  
time working with cocoon, so I'm not very familiar with its  
capabilities.  Is there something I can do to work around this problem?


Many thanks,
Rob Dockins

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message