cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christofer.Dutz@univativ.de" <christofer.d...@univativ.de>
Subject AW: Deploying Cocoon 2.1.10 Application in BEA Weblogic 9.2 Server
Date Fri, 09 Mar 2007 17:18:02 GMT
Hi,

 

after having a more detailed look at the deployment of WebLogic applications I found out that
my problems weren't related to Rhino, but to logging. 

The reason is the same though. I remember having similar problems with a JBoss project some
time ago. The solution was telling JBoss to separate the classpath of the server from that
of the application. This was the solution here too. 

 

By adding the following a file called "weblogic.xml" to the WEB-INF directory all problems
were solved and Cocoon works like a charm now J

<!DOCTYPE weblogic-web-app PUBLIC    "-//BEA Systems, Inc.//DTD Web Application 8.1//EN"
   "http://www.bea.com/servers/wls810/dtd/weblogic810-web-jar.dtd">

<weblogic-web-app>

    <container-descriptor>

        <prefer-web-inf-classes>true</prefer-web-inf-classes>

    </container-descriptor>

</weblogic-web-app>

 

Regards,

    Christofer Dutz

 

 

Von: Gabriele Columbro [mailto:columbro@gmail.com] 
Gesendet: Dienstag, 6. März 2007 13:01
An: users@cocoon.apache.org
Betreff: Re: Deploying Cocoon 2.1.10 Application in BEA Weblogic 9.2 Server

 

Hi Christofer, 
the problem of deploying Cocoon under Weblogic arises when using Flowscript and Mozilla Rhino
classes, because Weblogic embeds in its weblogic.jar rhino classes, thus not allowing override
of such classes with Cocoon modified version that you find in WEB-INF/lib folder (not even
using the <prefer-web-inf-classes> element in the WEB-INF/weblogic.xml file). 
The solution I adopted, following suggestions on the list, is to pull down both Cocoon and
Rhino sources in order to change org.mozilla package name to something different (the de 
facto standard for this seems to be org.nozilla ;-) ) so that it does not clashes with weblogic
shipped rhino classes.
For a more accurate  description of the problem please refer at [1] while you can find cocoon+rhino
sources here [2]. 
Please double check that the current rhino version is still the one I pointed you to, as my
work was referred to Cocoon 2.1.9.

Follows a script that once ran with the cocoon (or the rhino) folder as first argument will
perform the replacement: 

#!/bin/bash
# findNReplace.sh
# Find and replace useful to pull down Cocoon and Rhino sources to  work on weblogic 
# NB: must be applied to both cocoon and rhino sources for proper usage
# Author: Cocoon user list ;-)
#
# Parameters:
# $1 = directory in which cocoon/rhino installation can be found
#
DIR=$1
cd $DIR 
# Using sed replaces all occurences of org.mozilla --> org.nozilla backing up old versions
in "filename.moz-old"
for lsFile in `find . -type f -exec grep -q org.mozilla {} \; -print` ; do
    echo "Editing "$lsFile 
    mv $lsFile $lsFile.moz-old
    sed -r 's/org(.)mozilla/org\1nozilla/g' $lsFile.moz-old > $lsFile
    diff $lsFile.moz-old $lsFile
done
# Renames directories in order to make packages match
for lsDir in `find . -type d -name mozilla` ; do
    echo "Renaming "$lsDir" "`dirname $lsDir`/nozilla
    mv $lsDir `dirname $lsDir`/nozilla
done
~


HTH,
Gab



[1] http://www.planetcocoon.com/node/2443?PHPSESSID=7759547ab7c39b11fa439097c062da65 
[2]http://svn.cocoondev.org/repos/rhino+cont/trunk/rhino1_5R4pre 

On 3/6/07, Christofer.Dutz@univativ.de <christofer.dutz@univativ.de> wrote:

Hi,



I am currently working on deploying a cocoon application in WLS 9.2
unfortunately I am quite new to WLS and am having big trouble getting
the application to run. Is there anything I have to keep in mind when 
deploying on WLS 9.2? The application worked like a charm on tomcat for
quite some time, but we are migrating because of increased application
load.



Regards,

    Christofer Dutz




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org




-- 
----------------------------------------- 
Eng. Gabriele Columbro
Consultant at Sourcesense Italy 
-----------------------------------------
work: g.columbro@pronetics.it
private: columbro@gmail.com
mobile: (0039)3201612846 

yahoo: g.columbro
gtalk: columbro@gmail.com
AIM:   gabrielecolumbro

----------------------------------------- 
"Keyboard not found. 
Press F1 to continue" 
----------------------------------------- 


Mime
View raw message