cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lally Singh" <lally.si...@gmail.com>
Subject Re: Skipping cocoon-rcl-webapp-wrapper?
Date Mon, 05 Mar 2007 21:55:27 GMT
On 3/5/07, Grzegorz Kossakowski <grek@tuffmail.com> wrote:
> Lally Singh napisaƂ(a):
> > Hey all,
> >
> >
> cocoon-rcl has been updated lately to use new api of commons-jci.
> However, commons-jci is not released yet so some snapshot version is
> being used and that causes problems. Maven finds some old snapshot with
> old api and uses it for build resulting with an error. That's the price
> for depending on the unreleased artifacts...
>
> There are two solutions:
> 1. Remove cocoon-rcl from the build if you do not need it. You'll have
> to modify some poms.
> 2. Tell Maven to use newest version by doing this:
>
> svn checkout http://svn.apache.org/repos/asf/jakarta/commons/sandbox/jci/trunk commons-jci
>
> cd commons-jci
> mvn clean install -Dmaven.test.skip=true
> Skipping test could be necessary, at least for me they do not work.
>
> After that you should build your Cocoon normally. All this mess will be
> get sort out soon. (release of jci is planned)

Wonderful, thank you.  Cocoon builds normally gain.

Is there a similar situation with avalon-framework-impl?  Cocoon will
build, but as soon as I try and add hibernate/mysql to a simple block,
it dies.
org.apache.cocoon.core.container.spring.avalon.ConfigurationReader is
unable to find
org.apache.avalon.framework.configuration.DefaultConfigurationBuilder.build(InputStream,String).
Mime
View raw message